Cannot open links if Chrome is already Sandboxed.

After installing all the recent Windows 10 updates I can no longer open a link from any program in chrome if chrome is already opened and sandboxed.

 

Outlook/Skype/etc. If I have a link to any site and I click it nothing happens. Default browser is Chrome(Version 76.0.3809.100 (Official Build) (64-bit))

 

Running Sandboxie 5.31.2 64-bit beta.

If I disable forced programs, links open fine and will open chrome or open a new tab with the link as it should.

Or if I do not have chrome running/sandboxed already it will open a new chrome and sandbox it. If chrome is already running though, it will not open the link.

 

Only seems to be happening with Chrome, if I change default browser to FireFox(Which is also forced sandboxed) it opens fine.

 

Any ideas on how to resolve?

Thanks

  • Hi Tim,

    Please, follow the steps listed in this thread for another workaround (otherwise, your workarounds are the way to go)
    https://community.sophos.com/products/sandboxie/sandboxie-beta-versions/f/sandboxie-beta-5-31/113038/sandboxie-beta-sandboxie-beta-5-31-latest-version-5-31-2/410815#410815 

    For your convenience:
    Right-click on your Sandbox--> Sandbox settings --> Resource Access ---> Window Access 
    Hit Edit/Add and enter the below listed:
    *
    Apply and Okay your way out
    Delete the contents of your Sandbox, try reproducing the issue.

    Let me know how it goes. 
    Note: you will be opening a hole in your Sandbox, so proceed at your own discretion.  Our dev team is aware of the issue, and I will post any updates as soon as I receive them.


    Thanks!

  • In reply to Barb@Sophos:

    Hi,

     

    Thank you, this has resolved the issue. My question is now how big of a hole does this allow in the sandbox? And do you know if there is any timeline to have the issue resolved to avoid this work around?

     

    Thank you again for your time.

  • In reply to Tim Phillips:

    Hi Tim,

    Find more info about Win Classes below:
    https://www.sandboxie.com/OpenWinClass

    There is no ETA for a fix. 

    Considering the amount of workarounds available, I would rather do that instead of opening win classes, but it comes down to user preference/discretion.  

    Regards,

  • In reply to Barb@Sophos:

    Hi Barb,

    I do have the same experience with not able to open links in the emails in Sandboxed Outlook. However, on occasions, the links do open up in the sandboxed chrome.  Here is the sequence of events that appear to work at least for me. Again it is NOT consistent but most of the time works:

     

    1. Delete the content of Sandbox.

    2. Restart the laptop.

    3. Open up Outlook in Sandbox.

    4. Click on a link in an email message.

    5. Nothing happens.

    6. Close the Sandboxed Outlook.

    7. Open the Outlook un-sandboxed.

    8. Click on the link in an email.

    9. It opens up a non-sandboxed Chrome window and displays the web site.

    10. Close the Outlook and Chrome windows.

    11. Open up Outlook in Sandbox.

    12. Click on a link in an email message.

    13. A sandboxed Chrome window opens up displaying the web site.

    As mentioned, the sequence works most of the time but not all the time.

    I thought this may shed some light on the issue.

     

    Maxx