Mozilla Firefox dont start properly (no windows) while sandboxed

Hello everyone,

since a few weeks now i have a strange problem and nothing worked that ive tried.

Im using Windows 10 64-Bit (1903 since today; but problem also was here with 1809), Mozilla Firefox 67.0.1 64-Bit (but problemw as also there with earlier versions) and Sandboxie 5.30.

Problem stil exists even with disabled Add-ons and after deinstallation/reinstallation of FF.

I start FF either from Sandboxie (Start Web browser) or directly (setting is "start always in Sandbox). I can see in task manager that there are several FF processes; but i dont see the FF GUI. Outside of Sandboxie FF starts without a problem.

Sometimes, when i have started FF outside Sandboxie suddenly something will be opened in FF sandboxed (maybe i clicked a link in a different application).

Any ideas?

Greetings

 

Thomas

 

  • Hi Thomas,

    Start by deleting the contents of your Sandbox, and then if needed, testing in a new Sandbox with default settings.  

    If the problems persist, please, provide all the info as per guidelines so that we can test and assist you:
    How to report problems with Sandboxie

    Adding to the above listed, also include your configuration file:
    Configure--> Edit configuration
    Copy-paste the contents here.

    Thanks!

  • In reply to Barb@Sophos:

    Hi,

     

    new Sandbox didnt help.

    Here are my details:

    Windows 10 Pro 1903 (problem exists also prior update)

    Mozilla Firefox 67.0.2 64-Bit with the following extensions:

    - uMatrix

    - Turn off the lights

    - HTTPS Everywhere

    - Decentraleyes

     

    GDATA 25.5.3.4 (Web Protection is disabled)

    Starting FF outside Sandboxie works; inside Sandboxie it starts, but no GUI visible

    Grretings

     

    Thomas

     

    PS: here is the content of Sandboxie.ini:

     


    [GlobalSettings]

    Template=AdobeAcrobatReader
    Template=7zipShellEx
    Template=WindowsRasMan
    Template=SynapticsTouchPad
    Template=WindowsLive
    Template=GDataInternetSecurity
    Template=SnagIt
    Template=nVidia_Stereoscopic3D
    Template=OfficeLicensing
    Template=OfficeClickToRun
    ForceDisableSeconds=30

    [UserSettings_11FC028D]

    SbieCtrl_UserName=thomas
    SbieCtrl_NextUpdateCheck=1560612404
    SbieCtrl_UpdateCheckNotify=n
    SbieCtrl_ShowWelcome=n
    SbieCtrl_HideWindowNotify=n
    SbieCtrl_WindowCoords=250,324,974,556
    SbieCtrl_ActiveView=40021
    SbieCtrl_ProcessViewColumnWidths=250,70,300
    SbieCtrl_AutoApplySettings=n
    SbieCtrl_AlwaysOnTop=n
    SbieCtrl_ExplorerWarn=n
    SbieCtrl_RecoverTarget=C:\Users\Thomas\Downloads
    SbieCtrl_SaveRecoverTargets=y
    SbieCtrl_TerminateWarn=n
    SbieCtrl_BoxExpandedView=Firefox

    [UserSettings_29F403ED]

    SbieCtrl_UserName=adm.thomas
    SbieCtrl_ShowWelcome=n
    SbieCtrl_NextUpdateCheck=1558266750
    SbieCtrl_UpdateCheckNotify=n
    SbieCtrl_WindowCoords=7,0,1279,680
    SbieCtrl_ActiveView=40021

    [Firefox]

    Enabled=y
    ConfigLevel=7
    AutoRecover=y
    BlockNetworkFiles=y
    Template=qWave
    Template=WindowsFontCache
    Template=BlockPorts
    Template=LingerPrograms
    Template=Chrome_Phishing_DirectAccess
    Template=Firefox_Phishing_DirectAccess
    Template=AutoRecoverIgnore
    RecoverFolder=%{374DE290-123F-4565-9164-39C4925E467B}%
    RecoverFolder=%Personal%
    RecoverFolder=%Favorites%
    RecoverFolder=%Desktop%
    BorderColor=#00FFFF,ttl

     

  • In reply to Thomas Wallutis:

    Hi Thomas,

    Do other browsers start Sandboxed?
    Does the issue happen for both your user account and your admin one?(You have 2 users listed in the output)

    A few things to try:

    1 - Remove all the FF extensions (probably easier if you create a new Firefox profile under the current user) -> delete the contents of your Sandbox --> retest

    2 - If the above fails, with the new profile and an empty Sandbox do the following:
    Configure --> Software compatibility --> Find your GDATA template, remove it. Re-test [Try the same with the nVidia template if needed ]

    3 - If all fails, try removing your AV for testing purposes, reboot , delete the contents of your Sandbox and re-test (once confirmed whether Firefox works or not, please re-install your AV software - If it works without your AV, you'll need to find out exclusions for Sandboxie, here are some examples based on other antivirus software, exclude Start.exe""License.exe""SandboxieBITS.exe""SandboxieCrypto.exe""SandboxieDcomLaunch.exe""SandboxieRpcSs.exe""SandboxieWUAU.exe""SbieCtrl.exe""SbieIni.exe""SbieSvc.exe").

    Regards,

  • In reply to Barb@Sophos:

    Barb@Sophos

    Hello,

    > Do other browsers start Sandboxed?

     

    Yes. IE11, Chrome and Edge.


    > Does the issue happen for both your user account and your admin one?(You have 2 users listed in the output)

    Thats something i have to check.

    > A few things to try:

    > 1 - Remove all the FF extensions (probably easier if you create a new Firefox profile under the current user) -> delete the contents of your Sandbox --> retest

    Didnt solve it.

    > 2 - If the above fails, with the new profile and an empty Sandbox do the following:
    > Configure --> Software compatibility --> Find your GDATA template, remove it. Re-test [Try the same with the nVidia template if needed ]

    Didnt help either.

    > 3 - If all fails, try removing your AV for testing purposes, reboot , delete the contents of your Sandbox and re-test (once confirmed whether Firefox works or not, please re-install your AV

    > software - If it works without your AV, you'll need to find out exclusions for Sandboxie, here are some examples based on other antivirus software, exclude

    > Start.exe""License.exe""SandboxieBITS.exe""SandboxieCrypto.exe""SandboxieDcomLaunch.exe""SandboxieRpcSs.exe""SandboxieWUAU.exe""SbieCtrl.exe""SbieIni.exe""SbieSvc.exe").

    Havent tried deinstallation; but exclusions didnt help.

    Greetings

    Thomas

     

  • In reply to Thomas Wallutis:

    Hi Thomas,

    Thanks for the update. Sorry to hear the problems persist. I still cannot reproduce the behavior.
    Please, test removing the AV as suggested, and also test your other account to see if there is any difference in the outcome. 

    Another thing we can try is see what's trying to launch in the Sandbox when you invoke Firefox. 
    Create a new sandbox with default settings
    Use a clean firefox profile (no addons for this test)
    https://www.sandboxie.com/ResourceAccessMonitor
    Start Res. Acc. Mon
    Immediately repro the issue and copy the contents of Res. Acc. Mon to your response

    Regards,

  • In reply to Barb@Sophos:

    Hi,

     

    thats interesting. Without AV (GDATA) it works; even with AddOns.

    But when i reinstall GDATA, it works until i do the first Signature-Update.

    This is somehow...strange...

    Greetings

     

    Thomas

     

  • In reply to Thomas Wallutis:

    Hi Thomas,

    Third party software, such as AVs, may interact with Sandboxie, it is not strange unfortunately.

    Here's the known conflicts AV section (the forums links won't work, but you can see suggestions for troubleshooting and what to add to exclusions) :
    https://www.sandboxie.com/KnownConflicts#Anti-virus%20Related 

    Give that a try, there are several entries per AV, I would suggest you try the exclusions route first. You may want to reach out to your AV software support for suggestions as well, now that we have determined that your AV is blocking it. 

    Regards,

  • In reply to Barb@Sophos:

    Hi,

    it seems that the Exploit Protection in GDATA is the problem here. When i deactivate it, the problem vanishes.

    Greetings

     

    Thomas