This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

UTM 9.601 - RED issues!

Since upgrading all our customers to 9.601, a bigger part of them are complaining about RED's re/disconnection in a no-pattern way.

It started for all of them just the night we upgraded to 9.601, and they all are on different ISP's and located different places around the country.

Been with Sophos support for 2 hours today, and now they escalated it to higher grounds.

Will return with an update....

Suspicious entries in the log - but all connected REDs do this before connection:

2019:03:06-15:15:38 fw01-2 red_server[17509]: SELF: Cannot do SSL handshake on socket accept from '': SSL connect accept failed because of handshake problems

2019:03:06-15:15:46 fw01-2 red2ctl[12420]: Missing keepalive from reds3:0, disabling peer

I know the last line is written before the tunnel disconnects, because there was no "PING/PONG" answer...

One customer has 2 x RD 50, one 1 100% stable and the other fluctuates in random intervals - we replaced this with a new RED 50, but the same thing occurs.

This thread was automatically locked due to age.
  • Same issues here after 9.601-5 UTM update. 2x RED50 Rev 1. Drop multiple ISPs at varying intervals and lengths. It was advised to re-create RED in UTM. I have performed this, but problems still persist. I was sent two replacement RED50. The first one has been replaced, a new config created, but problem persists. ISPs modems have been replaced although they were reluctant to do so. One of the REDs wont recognize the presence of ISP on WAN1 at all.

    We are losing a lot of productivity and business. We do a sizeable portion of our business via teleconferencing.

    Support Tickets#





    The tech alluded to a potential issue with REDs after the update to 9.6.01-5.

  • My problem is resolved. There is a known issue related to unified firmware.

    from su -

    cc get red use_unified_firmware

    if value returned = 1

    cc set red use_unified_firmware 0

    reds will update and reboot

    confirm value is 0 rerunning get command above


    NOT A PERMANENT FIX. The issue needs to be addressed in Sophos UTM firmware permanently.

  • Hi there!

    We made an Update to 9.604-2 with our both SG125.

    Our 5 RED15-Devices going offline. 

    The Workaround helps to 4 came back online.

    Bit 1 Device wil not!!! That is business mission critical!

    I set the MTU of the interface to 1400. DONT help.

    I delete the RED an re-create. DONT help.

    I see a permanent Loop in the Log:

    2019:07:30-07:56:55 rkdfw001-1 red_server[19875]: SELF: New connection from X.X.X.X with ID XXXXXXXXXX (cipher AES256-GCM-SHA384), rev1
    2019:07:30-07:56:55 rkdfw001-1 red_server[19875]: XXXXXXXXXX: connected OK, pushing config
    2019:07:30-07:56:56 rkdfw001-1 red_server[19875]: XXXXXXXXXX: command '{"data":{"version":"0"},"type":"INIT_CONNECTION"}'
    2019:07:30-07:56:56 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Initializing connection running protocol version 0
    2019:07:30-07:56:56 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Sending json message {"data":{},"type":"WELCOME"}
    2019:07:30-07:56:57 rkdfw001-1 red_server[19875]: XXXXXXXXXX: command '{"data":{},"type":"CONFIG_REQ"}'
    2019:07:30-07:56:57 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Sending json message {"data":{"pin":"","fullbr_dns":"","split_networks":"","lan2_vids":"","lan4_vids":"","local_networks":"","tunnel_id":2,"manual2_netmask":24,"asg_cert":"[removed]","manual_address":"","bridge_proto":"none","unlock_code":"xxxxxxx","password":"","manual2_defgw":"","prev_unlock_code":"rlvqiegl","manual_netmask":24,"lan3_vids":"","version_r2":"2005R2","mac_filter_type":"none","mac":"xxx","dial_string":"*99#","manual2_address":"","version_ng_red50":"5211","manual_dns":"","lan1_mode":"unused","username":"","activate_modem":"0","tunnel_compression_algorithm":"lzo","version_red50":"5211","fullbr_domains":"","uplink_balancing":"failover","asg_key":"[removed]","type":"red15","deployment_mode":"online","uplink2_mode":"dhcp","version_red15":"5211","manual2_dns":"","lan2_mode":"unused","debug_level":0,"local_networks_target":"","fai...L1421
    2019:07:30-07:56:59 rkdfw001-1 red_server[19875]: XXXXXXXXXX: command '{"data":{"device":"RED15","type":"tar.gz","version":"5211"},"type":"FW_FILE_REQ"}'
    2019:07:30-07:56:59 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Requesting firmware file /usr/share/red-firmware//red15-v5211.tar.gz
    2019:07:30-07:57:13 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Sending json message {"data":{},"type":"FW_FILE_FIN"}
    2019:07:30-07:57:13 rkdfw001-1 red_server[19875]: XXXXXXXXXX: command '{"data":{"device":"RED15","type":"md5sum","version":"5211"},"type":"FW_FILE_REQ"}'
    2019:07:30-07:57:13 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Requesting firmware file /usr/share/red-firmware//red15-v5211.md5sum
    2019:07:30-07:57:13 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Sending json message {"data":{},"type":"FW_FILE_FIN"}
    2019:07:30-07:57:15 rkdfw001-1 red_server[19875]: XXXXXXXXXX: command '{"data":{"message":"Successfully downloaded firmware version 5211 from UTM"},"type":"DISCONNECT"}'
    2019:07:30-07:57:15 rkdfw001-1 red_server[19875]: XXXXXXXXXX: Disconnecting: Successfully downloaded firmware version 5211 from UTM
    2019:07:30-07:57:15 rkdfw001-1 red_server[19875]: id="4202" severity="info" sys="System" sub="RED" name="RED Tunnel Down" red_id="XXXXXXXXXX" forced="1"
    2019:07:30-07:57:15 rkdfw001-1 red_server[19875]: XXXXXXXXXX is disconnected.

    How can i fix this??

    Best Regards!


  • Hi BAlfson, All,

    That is not entirely what I am saying. The issue we have within the RED50 is that the old firmware is having issues when applying the new firmware, hence switching off the unified firmware might not prevent this from happening in case the RED50 has the unified firmware installed on it, as this might cause the issue to happen when applying the not unified firmware. The same unfortunately can happen with the new MR5 firmware as well, as it will be applied by the old faulty firmware.

    What we have found in our testing is that the issue is likely only to occur in cases when the RED50 is under load when the firmware update is being started, hence the recommendation to put the network behind the RED50 offline for the update. This does not mean taking the RED50 itself offline, it needs to stay online to get the new firmware.

    Ones the RED50 has the MR5 firmware installed, the issue is fixed and following firmware updates will not require these steps.

    Hope this provides a little more background.



  • Hi Phill,

    can you please reach out to Sophos Support for getting this analyzed and addressed?



  • Still not comfortable, Jan...

    What is MR5 firmware?  Does this also fix the same problem with the RED 15s?  Many RED 50s and RED 15s were knocked offline and some RED 50s were bricked.    What is "the issue" or are these the same issue?

    How does one "put the network behind the RED50 offline for the update" and where is that recommendation to be seen?

    Cheers - Bob

    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • We have 3 RED50s deployed in other states. There is no IT staff at the remote sites. If these things go down, we have no Email, CRM. telephones, nothing. I've been holding off on updates due to this very problem.

    What's my guaranteed, iron-clad way of updating without no unforeseen downtime?


  • Hi All,

    2019-08-06 See my final version posted today

    UPDATED 2019-08-01

    I've had several messages back and forth with Sophos folks.  As Jan Weber says in a post, 9.605 fixes the problem with REDs and the only danger is updating the RED firmware when the RED is under a heavy load.  I have suggested that the following instructions be added to the information about the Up2Date (I in blue dot) and the blog post about the 9.605 Up2Date:

    In order to ensure that there's no problem with the update of firmware in RED devices, do the following with two planned outages:

     1. Outage 1 - Up2Date to 9.604:
         A. In WebAdmin, disable all RED Servers for RED appliances.
         B. Apply Up2Dates through 9.604.
         C. At the command line: cc set red use_unified_firmware 0
         D. In WebAdmin, enable all RED Servers for RED appliances.
     2. Outage 2 -
    Disconnect all LAN connections from all REDs, leaving the RED online but with no connection to local clients.
     3. Apply the 9.605 Up2Date.
     4. After the Up2Date is complete, reconnect disconnected LAN cables to the REDs.

    Cheers - Bob

    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Hello everyone,


    one question about getting the heavy load from the RED: most of our REDs are in branch offices (what the RED is build for, I would think) without any IT personell there, and a few hundret miles between us and them. Normaly, we are making the Sophos updates in timeframes where these offices are empty and there should be no load at all, but to be sure we want of course to disable all connections.

    The question: would it help to disable the interfaces of the RED on the sophos side without disableing the RED itself? Or would this still produce "malicious" workload on the RED side?





  • thanks to Jan for the information.

    but concretely what we have do to for reuse the RED50s that can no longer connect?

    Our head office is in Italy and we have a RED50 in turkey that, after updating to 9.6, is unusable: the device always remains in BOOTING, then the error led turns on and then restarts.

    The RED50 is not under maintenance contract: how should I proceed?

    Thanks in advance.



  • Hi Tobias,

    disabling the RED interfaces will not help, in case there is no traffic from the branch through the RED because of time of day, that could already provide the 'less load' scenario. However to be sure it is advisable to disconnect all LAN ports on the RED itself.


  • Hi Fabio,

    The only option to recover a RED50 that is in this state is via an RMA with support.


Reply Children
  • Hi Jan,


    but is possible to start an RMA procedure without a maintenance contract?





  • Fabio Giacobbe said:

    Hi Jan,


    but is possible to start an RMA procedure without a maintenance contract?






    When having license for reds (network protection), you should be covered ;-)


    Best regards

    Sophos XGS 2100 @ Home | Sophos v20 Architect

  • You are correct, Fabio, that the standard rule is that there's a 1-year warranty on REDs connected to UTMs.  I think that given that the problem was most likely caused by an Up2Date, Sophos might go ahead and replace the RED.

    If it turns out that you can't get a free replacement, my recommendation is to replace a RED 50 with an SG 115 with a Network Protection subscription.  That will give you more flexibility and will cost less over time than a RED 50 with Warranty Extensions.  You can configure a RED tunnel in your main office UTM and just replace the reds# in your existing Interface definition with the new one.  Depending on your present configuration, there might be very little needed to configure the new SG 115.

    Please let us know what you tried and the results.

    Cheers - Bob

    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA