Advisory: Sophos Endpoint - "Your connection isn't private." We're aware of a certificate issue and are actively working to resolve it. Please see: KB-000045954 for the latest updates.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Block Entire Top Level Domains - edit to exit.conf no longer works.

I have upgraded to 9.706-8.
Previously, I used info in this (closed) thread:
to block all emails from *.tech, *.info, etc TLDs as they are always spam for us.
Basically, what I did was:
  • su
  • Make a backup: cp /var/storage/chroot-smtp/etc/exim.conf /var/storage/chroot-smtp/etc/exim.conf.original
  • joe -help /var/storage/chroot-smtp/etc/exim.conf
  • Comment out the “SENDERBLACKLIST” line
  • Add this line directly below it: senders = SENDERBLACKLIST/REF_SMTPGlobalProfile
  • Exit and save - ^KX
  • Restart the SMTP proxy: /var/mdw/scripts/smtp restart
  • In webAdmin, add *@*.info *@*.tech etc to the Host/Network Blacklist of SMTP/Advanced
This no longer works. SMTP log shows:
2021:05:11-11:38:00 astaro1-1 exim-out[25815]: 2021-05-11 11:38:00 End queue run: pid=25815
2021:05:11-11:38:00 astaro1-2 exim[45905]: [1\2] 2021-05-11 11:38:00 Exim configuration error in line 14 of /etc/exim.conf:
2021:05:11-11:38:00 astaro1-2 exim[45905]: [2/2] main option "senders" unknown
2021:05:11-11:38:00 astaro1-2 exim[45906]: [1\2] 2021-05-11 11:38:00 Exim configuration error in line 14 of /etc/exim.conf:
2021:05:11-11:38:00 astaro1-2 exim[45906]: [2/2] main option "senders" unknown
Any idea how to do this now?
Thanks, James.


This thread was automatically locked due to age.
Parents Reply Children
No Data