This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

emails stuck in smtp spool with error

hello i have got 2 emails being sent to the same email address that are stuck in the smtp spool with error state, i did a retry to resend the emails but again they were put back in the smtp spool. The emails have an attachment of 7mb and 12mb respectively. How can i release the emails?



This thread was automatically locked due to age.
Parents
  • Thanks for your reply FormerMember 
    Outbound emails are sent without an attachment, but when you add an attachment the error in smtp spool is Scanner timeout 

  • FormerMember
    0 FormerMember in reply to ssali prosper

    Hi ,

    Thanks for the update. 

    Would it be possible for you to share the screenshot of how the SMTP route and scan policy configured on the firewall? 

    We'd need to check the smtpd_main logs in debugging to identify the issue. 

    Follow the steps to put the smtpd service in debugging, try to send an email with an attachment, and collect the smtpd_main logs, and you may obscure your email and IP address for discretion. 

    Follow this KB Article to SSH into the XG firewall: Sophos XG Firewall: How to SSH to the firewall using PuTTY utility

    Select Option 5 (Device Management) > Option 3 (Advance Shell)

    Run this command to put the smtpd service in debug:

    • service smtpd:debug -d -s nosync

    Please check out the following KBA to locate and capture the logs: Sophos XG Firewall: Where to find log files?

    Once you capture the access_server logs in debugging, run the same command to put smtpd service in normal running mode. 

    Run this command to check service status :

    •  service -S | grep smtpd

    Thanks,

Reply
  • FormerMember
    0 FormerMember in reply to ssali prosper

    Hi ,

    Thanks for the update. 

    Would it be possible for you to share the screenshot of how the SMTP route and scan policy configured on the firewall? 

    We'd need to check the smtpd_main logs in debugging to identify the issue. 

    Follow the steps to put the smtpd service in debugging, try to send an email with an attachment, and collect the smtpd_main logs, and you may obscure your email and IP address for discretion. 

    Follow this KB Article to SSH into the XG firewall: Sophos XG Firewall: How to SSH to the firewall using PuTTY utility

    Select Option 5 (Device Management) > Option 3 (Advance Shell)

    Run this command to put the smtpd service in debug:

    • service smtpd:debug -d -s nosync

    Please check out the following KBA to locate and capture the logs: Sophos XG Firewall: Where to find log files?

    Once you capture the access_server logs in debugging, run the same command to put smtpd service in normal running mode. 

    Run this command to check service status :

    •  service -S | grep smtpd

    Thanks,

Children
  • Above is the screenshot of mail manager in sophos utm 9 webadmin where am trying to release all those mails but they keep returning back to the smtp spool.

    On viewing the message delivery log says Scanner Timeout

  • Hi Ssali and welcome to the UTM Community!

    What version of UTM - 9.705?  What hardware is this running on?  Model or RAM & CPU if not a Sophos appliance.

    Please copy here the lines from the SMTP Live Log when you Retry releasing one of those mails.

    Does this happen with any other sender?  With any other recipient?

    Cheers - Bob

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA