PiHole hinter UTM --> nur UTM als Client angezeigt (NAT-Problem?)

Hallo zusammen,

Seit kurzem konnte ich meinen Anschluss auf BridgeMode umstellen, was insgesamt ein paar Änderungen/Umstellungen zur Folge hatte:

Mein PiHole wurde reaktiviert, befindet sich im internen Netz und funktioniert so weit wunderbar: Die Clients benutzen die UTM als DNS und alles ander macht der PiHole als Verfügbarkeitsgruppe mit verschiedenen anderen DNS-Servern. Allerdings wird im PiHole immer nur die IP der UTM als Client angezeigt, nicht die der einzelnen Clients selbst. Damit funktioniert zwar alles, aber eine Unterteilung einzelner Client-Groups oder ähnlichem beim PiHole ist damit nicht möglich.

Ich gehe schwer davon aus, dass ich da noch eine NAT-Einstellung vornehmen muss, aber irgendwie will das nicht in meinen Kopf hinein, was genau ich da einstellen muss.

Hat da vielleicht wer nen Tip für mich? Das ganze S-NAT, D-NAT, etc. bringt mich mehr und mehr durcheinander.

Gruß
Marian

  • Wenn alle die UTM als DNS-Server fragen und die UTM dann zum PiHole geht, sieht dieser natürlich nur die UTM als Client/anfragenden.

    Besser die Clients gehen direkt zum PiHole und dieser dann weiter zur UTM.

    ... und verbiete UDP 443 an der Firewall. Damit "schummeln" Browser Anfragen an der FW/dem konfigurierten DNS Server vorbei zu ihren eigenen name-Servern.


    Dirk

    Systema Gesellschaft für angewandte Datentechnik mbH  // Sophos Platinum Partner
    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.

  • Hallo Dirk,

    wo weit, so klar. Aber ich nahm an, dass ich das in der Sophos entsprechend so konfigurieren kann, dass die Client-IPs entsprechend "durchgereicht" werden.

    Wenn ich den PiHole direkt per DHCP als DNS vermittele sehe ich alle IPs korrekt, das habe ich jetzt ausprobiert. Aber funktioniert dann noch meine Verfügbarkeitsgruppe, sollte der PiHole mal ausfallen?

    Das mit dem UDP 443 wusste ich auch noch nicht, danke für den Tip. Man lernt halt nie aus.

    Gruß
    Marian

  • Die Verfügbarkeitsgruppe funktioniert dann so einfach nicht mehr ...

    Du könntest die XG als 2. DNS an die Clients verteilen/eintragen.


    Dirk

    Systema Gesellschaft für angewandte Datentechnik mbH  // Sophos Platinum Partner
    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.

  • 1. und 2. DNS wird leider von Windows nicht ordnungsgemäß priorisiert. Heißt, es kann immer wieder passieren, dass der Client die UTM als DNS nimmt, obwohl der Pihole als 1. DNS erreichbar ist.

    Dann ist der Pihole teilweise ausgehebelt, was ja auch nicht Sinn der Sache ist.

    Dann bleibt es wohl erstmal bei der Verfügbarkeitsgruppe und der UTM als einzigen Client im PiHole, bis sich eine andere Lösung findet.