Important note about SSL VPN compatibility for 20.0 MR1 with EoL SFOS versions and UTM9 OS. Learn more in the release notes.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Telegram Messenger Not Connecting When Any Web Policy is Active

Original post here got locked:  Telegram Messenger Not Connecting When Any Web Policy is Active 

Application classification on or off makes no difference.

I've tried adding web filter exceptions for

but that hasn't helped either.

If I set the Web Policy to anything other than "None", Telegram fails to connect. Even the default "Allow All" policy prevents it from connecting.

I've tried with both web proxy and DPI engine as well. Neither one makes any difference.

I see nothing in the logs being blocked.

Also of interest is Telegram on Windows desktop is not being blocked. It seems to only be the iOS version that's having issues.

This thread was automatically locked due to age.
  • Have you checked the following things:

    That you have decryption bypassed/disabled for iOS devices if "inspect HTTP and decrypted HTTPS" and/or "Decrypt HTTPS during web proxy filtering" is enabled in the firewall rule that allows the iOS device?

    That in the TLS/SSL Inspection Rules, you are not attempting to "Decrypt" iOS device in the settings.

    Check your firewall logs and "SSL/TLS Inspection" logs for Blocked Insecure SSL/TLS

    A quick google search for Telegram states it uses it's own encryption called MTProto, so my guess is the firewall is blocking insecure encryption when web filter is on.

    Telegram uses a custom build symmetric encryption scheme called MTProto. The protocol was developed by Nikolai Durov and other developers at Telegram and is based on 256-bit symmetric AES encryption, 2048-bit RSA encryption and Diffie–Hellman key exchange.
  • Thanks for this info. I am out of town for the next week but will check this when I return.

Reply Children
No Data