Problem with STAS uninstall

Hi all,


I have installed STAS version on a 2008R2 DC. Now I wanted to upgrade that installation to version

If I run the new setup file I keep getting the message "STAS is running, Please close the application and try again". But the STAS Config is closed and the STAS service is stopped and set to "Disabled". I have no clue why I keep getting this error message.

If I try to uninstall STAS first, I get the same message. Also I tried to restart the server... nothing helps.


Has anyone had a similar problem?


Thanks for your help.

  • Hi  

    I haven't seen any such instances where STAS could not be uninstalled. Please create a case with Sophos Support to identify this issue. It would require to check the process status in the Windows server.

  • This sounds like a Windows Server issue to me.  What was done to resolve this?

    Cheers - Bob

  • In reply to BAlfson:


    I tried a lot of things. I had the same problem on all other DC's, even with the actual version

    I even tried to use a uninstall tool, to force uninstallation. After that I still got the same message.


    What I had to do to, to do a new install, was to delete all registry keys under HKLM\SOFTWARE\Wow6432Node\Sophos

  • In reply to polyrack:

    It's great that you found a solution!  Please make sure the Sophos Support team knows what you learned.

    Cheers - Bob