Fehlermeldung beim Versuch Sophos Mobile Security zu installieren

Hallo,

wir haben einige Handys, auf denen Sophos Mobil Control (SMC) und Sophos Mobile Security (SMS) installiert werden soll.

Es handelt sich bei allen Geräten um Samsung XCover 4s mit Android 9.

Die Geräte sind neu und werden erstmalig installiert.

Wir haben dafür ein Google for Work - Account eingerichtet. Dieser ist auch in Sophos Central verbunden.

Nach dem Start werden die Ersteinstellungen normal abgearbeitet und beim Google-Account afw#sophos eingegeben.

Danach wird SMC normal installiert. Es erfolgt die Synchronisation (Auftragspaket, Richtlinien, …).

Im Anschluss wird man auf dem Handy aufgefordert, SMS zu installieren, wie es auch nach den Aufgabenpaketen gefordert ist. Dazu öffnet sich dann der Google Play Store.

Es wird direkt zum Programm gesprungen. Tippt man hier nun auf "Installieren", so erfolgt die Fehlermeldung:

Geht man zurück, so werden nur die Apps angezeigt, die auch genehmigt sind.

Und KEINE davon lässt sich installieren. Bei allen kommt die gleiche Fehlermeldung.

Hat dies schon mal wer gehabt oder kennt dazu eine Lösung?

Danke

 

Nachtrag: Wenn ich bei der Handy Einrichtung direkt einen Google Account eingebe und auf afw#sophos verzichte, dann kann ich die Apps installieren. Ist jedoch keine Lösung, da ich momentan nur den Admin-Account habe und mir nicht bekannt ist, wie ich unter Accounts anlegen kann.

  • Hi  

    Could you please suggest if you are receiving the same error on more than one device or it is just happening with the one device? It would be great if you can provide the error in English or you can translate it into English for me.

  • Hi Karsten Kallenbach,

    Do you mean to say that it is happening only when the task bundle is pushed to the devices?

    Are you using Sophos Central or On-premise mobile?

    Regards,

    JR

  • Hallo,

     

    ich hatte mal ein ähnliches Problem beim Installieren einer App. Später ist mir aufgefallen, dass die Uhrzeit auf dem Gerät nicht stimmte. Nach der Korrektur konnte ich auch die App installieren. Ist möglicherweise eine falsche Zeitzone oder so eingestellt?

     

    English:

    I had a similar issue with another app. Later I recognized that the time was wrong on the device. After entering the correct time the app could be installed. Maybe the timezone is wrong on the devices?

  • In reply to Jelle:

    Hallo,

    danke für die Antworten.

    Ja, der Fehler trat bei mehreren Geräten auf.

    Es hatte leider nichts mit der Uhrzeit auf dem Gerät zu tun.

    Wir benutzen Sophos Central.

     

    Lösung:

    Ich habe durch Versuch und Irrtum herausgefunden, dass es mit der Compliance-Richtlinie zu tun hat.

    Ändert man bei "Apps aus unbekannten Quellen erlauben" und "Android Debug Bridge (ADB) erlaubt" auf "Ja", so funktioniert alles einwandfrei.

    Das entspricht zwar nicht dem Handbuch oder meiner Logik, aber was solls.

    Da ich per Hand noch ein Programm installieren musste, das nicht im Play Store verfügbar ist, kam mir die ADB-Erlaubnis auch zu pass.

     

    Danke für die Lösungsvorschläge,

    Karsten

     

    --------------------------- English by Google -------------------------  :-)

    Hello,
    Thanks for the answers.
    Yes, the error occurred on several devices.
    Unfortunately, there was nothing to do with the time on the device.
    We use Sophos Central.
    
    Solution:
    I have found by trial and error that it has to do with the compliance policy.
    Changing to "Allow apps from unknown sources" and "Android Debug Bridge (ADB) allowed" to "Yes", everything works fine.
    Although this is not the manual or my logic, but what the hell.
    
    Since I still manually install a program, the Play Store is not yet available.
    
    Thanks for the solutions,
    Karsten
  • In reply to Karsten Kallenbach:

    Das ist ja interessant. Apps aus unbekannten Quellen ist bei uns deaktiviert, aber die Android Debug Bridge war bisher zugelassen. Habe diese jetzt auch mal auf "Nein" gestellt und werde beim nächsten Gerät mal schauen was passiert.

  • In reply to Jelle:

    Täte mich interessieren, was bei Dir rauskommt. Daher wäre es nett, wenn Du das hier kurz posten könntest.

    Ich bin erstmal froh, dass ich die MDAs (25 Stück) alle soweit zum Laufen bekommen habe.

    Testen werde ich frühesten Ende des Monats nochmal. Dann bekomme ich noch mal einige Geräte dazu. Tongue Tied

  • In reply to Karsten Kallenbach:

    Also nachdem ich ADB deaktiviert habe funktioniert es immer noch. Ich habe zwar nach wie vor das Problem dass manchmal die Richtlinien nicht vollständig ausgeführt werden und ich Teile zu Fuß einrichten muss, aber es geht insgesamt.

  • In reply to Jelle:

    Danke für die Antwort. Ich werde es hier bei Gelegenheit auch nochmal testen.

     

    Gruß

    Karsten