Advisory: Support Portal Maintenance. Login is currently unavailable, more info available here.

Compatibility CAA - Mac Catalina - bug

Installing Sophos Client Authentication agent on Mac Catalina, the client is not usable as the "server is not trustworthy"

I am not able to add the certificate der file inside shared folder.

CAA version is 2.0.0, downloaded from XG v18 Client Authentication menu

 

Regards

Parents
  • FormerMember you said you couldn't copy the file over to Shared. Is there an error popping up? Have you tried copying it via Finder instead?

  •  

    Yes, I tried manually. Same behaviour!

    The same behaviour on 17.5 MR8

    Regards

  • Looks like a regression from Apple - just like with iOS 13, will take a look at it asap. 

  • As Stuart mentioned, this is likely caused by changes Apple have made to the required certificate criteria when they authenticate certificates.

    We are planning to update the generation of the default Appliance Certificate to meet these new criteria but were unable to get this done in time for this EAP release, unfortunately. We also expect to make this change in an upcoming MR for version 17.5.

    In the meantime, to support users running Catalina or iOS13, you should look at using a certificate that is signed on a different system, which meets the criteria set out in the Apple article. You can create a CSR and the accompanying private key on the XG firewall, but the signing process, which will set the expiry date and the 'Purpose' fields, will need to be carried out on a system where you can ensure the right values are set. We'll investigate further and try to come up with some more specific instructions soon.

  • FormerMember as expected, there are some changes in the latest macOS that target folders and permissions. Indeed, the CAA installer can't be used anymore to copy the CA inside the /Users/Shared folder.

    As a workaround, after mounting the downloaded .dmg file, use 2 Finders to drag and drop the certificate from the CAA image to /Users/Shared. Eventually, you will be asked for the user password before the operation can be executed. In any case, it will work.

    Now you can authenticate the user, no popup should be seen (assuming the right XG is still the default gateway). The Trust API still works for CAA, no extra steps needed.

  •  

    you workaround does not work. I tried already your method (certificate copied 10th of october) but same issue.

    XG is the DG.

  • I see. Let's take it privately and work together on it, if possible. We can't reproduce this here yet.

Reply Children