DNS across VLANs

Hey,

So I have this DHCP

VLANS all like this

and DNS like this

From any computer in VLAN 100 I can ping another computer in VLAN100 like this

ping cws-yellow-room

But, if I try to ping a server (by name and not IP) that is on a different vlan (vlan200) it can't resolve the name.

I.e. how can I can the DNS to work across the VLANS.... 

Note: I have added a record to the 'DNS Host Entry' section to line the name to the IP and that did nothing so I removed it again.....

Thanks!



Edited TAGs
[edited by: emmosophos at 5:14 PM (GMT -7) on 16 Aug 2022]
Parents
  • Ok, so after all the help from below, it kind of works......

    I changed the DNS on the DHCP etc and added the DNS Host entry on the XGS  and the NSLOOKUP works but I always need to add a '.' to the end of the server name for ping and folder shares

    It seems like the sophos DNS suffix is different to the one of the computers? I.e. the computers don't have one.... but when I add the full stop it treats it differently and can resolve the name to the IP..... I believe adding the full stop forces it to be treated as a fully qualified domain name.

    Thoughts? Is there a 'suffix' on the sophos DNS?

  • Do you configure the "domain name" within DHCP?

    DNS normally need the FQHN ... mean name+domain-name.

    Using short names (only the hostname)  is using netbios/broadcasts ... or try to add the domain-suffix for DNS.

    Between hostname and DNS-suffix you have to place a dot ... without suffix (empty suffix) it should look like "hostname." 


    Dirk

    Systema Gesellschaft für angewandte Datentechnik mbH  // Sophos Platinum Partner
    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.

  • Interesting, on the mac the '.' is not required on the w10 PC it is.

    Ian

    XG115W - v19.0.1 mr-1 - Home

    1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP - on holiday.

    If a post solves your question please use the 'Verify Answer' button.

  • No, the 'Domain Name' field in the DHCP setup on the XGS is blank.

    When I ping a 'hostname' on the same VLAN it works as 'normal', so e.g. "ping cws-yellow-room' works fine.

    Only when I try to ping across VLANs does it want the '.'

    Is there a way to avoid this?

  • Hello Robin,

    as Dirk Kotte already wrote: you need FQDN for this to work. NetBIOS names won't work.

    FQDN = cws-server-01.domain.internal  (with "domain.internal" being your internal domain suffix)

    NetBIOS = cws-server-01

    Windows Clients normally add "their" DNS-Suffix to the hostname, if this is configured.

    That's the reason it sometimes "seems to work" without FQDN.

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

  • Hey,

    Yeah sorry that last part is what I was trying to ask. 

    I.e.

    "Windows Clients normally add "their" DNS-Suffix to the hostname, if this is configured.

    That's the reason it sometimes "seems to work" without FQDN."

    Is that a config on the DNS setup like adding 'domain name' to the DHCP for both vlans to be the same (which they are are the moment, they both empty.... but would an actual domain change this), or is it more a windows thing.

  • Some devices auto assign .local or .localhost which does not show when network testing.

    Ian

    XG115W - v19.0.1 mr-1 - Home

    1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP - on holiday.

    If a post solves your question please use the 'Verify Answer' button.

  • There is a DHCP option to set the domain name: option 15 = domain name. This is the DNS type of name = domain.internal, not onle "domain" With windows clients it has been a good practise to set the node type with DHCP option 46 to "H-node" (Hybrid) = 8

    This forces the windows clients to use DNS and NetBIOS.

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

Reply
  • There is a DHCP option to set the domain name: option 15 = domain name. This is the DNS type of name = domain.internal, not onle "domain" With windows clients it has been a good practise to set the node type with DHCP option 46 to "H-node" (Hybrid) = 8

    This forces the windows clients to use DNS and NetBIOS.

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

Children
No Data