Upgrading XG115 from SFOS 18.0.6 MR-6 to SFOS 18.5.1 MR-1: Backup restore not working?

Hey everybody,

I'm trying to upgrade a XG115 appliance from SFOS 18.0.6 to SFOS 18.5.1.

I've created a backup of the config from within the 18.0.6 firmware and downloaded and installed the 18.5.1 release .

All settings were reset to factory defaults, which was to be expected.

However, I'm unable to restore the 18.0.6 backup.

The process simply errors out, complaining that the backup can not be applied to this firmware version.

Can someone give me a hint how exactly one is supposed to upgrade the firmware without losing the configuration?

Thanks in advance,

Dominik



Added TAGs
[edited by: emmosophos at 4:42 PM (GMT -8) on 4 Jan 2022]
  • HI,

    for some odd reason, I think you have to migrate from mr5. You might check the release notes for mr6 for compatibility issues.

    Ian

    Xeon 1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP

    XG115W - v18.5.2

    If a post solves your question please use the 'Verify Answer' button.

  • Thanks for answering!

    It might be worth a shot. Any idea how I would go about this? Can I roll back from MR6 to MR5 without having to do a reinstall?

    Where can I even get the MR5 firmware? This is everything being offered to me in the download section:

  • I have the same issue.  Went from 17.5.11 to 18.0.6 build655 and now I can't go to 18.5.1 build 326 unless I want to boot factory default.

  • Well, at least I'm not the only one then :-)

    Man, I miss the good, old UTM days....back when men were men, women were women and firmware upgrades were simple firmwareupgrades that went through without a hitch :-)

  • I dont understand. UTM Firmware upgrades are madness compared to this. (Try to do this task on UTM. Have fun downloading 10 Files and be careful which one you use. See UTM download server). 

    Never the less:

    Simply use V18.5 MR2. It will support a upgrade from V18.0 MR6. It will also support a restore of you current version. 

    __________________________________________________________________________________________________________________

  • I don't understand your comment about the UTM upgrades, last time I used a UTM it was one file for all users the installation worked based on your licence, are you saying Sophos has broken the UTM upgrade into many smaller parts?

    Ian

    Xeon 1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP

    XG115W - v18.5.2

    If a post solves your question please use the 'Verify Answer' button.

  • See: https://download.astaro.com/#UTM/v9/up2date/

    You need to have the "complete chain" of updates available on the appliance.

    On SFOS, you need one file, it will convert the configuration to the version. So you can upload simply "V18.5 MR2" and it will bring you there from every version.

    On UTM you need to upload all files, from source version to the target version. You can eventually do the "bring me to the latest version" but it will do the same kind of mechanism. Installing each and every update one by one. This was the process for decades. So i cannot understand, how this was in any kind a better process compared to the approach in SFOS. 

    __________________________________________________________________________________________________________________

  • With the UTM there updates were/are in a logical numbered order. Whereas the XG the numbering is not logical, you can't upgrade say v17.5.6 to v17.5.16, you need to go to mr12, then you can't go from mr16 to v18.0.6, voy need to go through v18.0.5 and to get to v18.5.6 you need to got through v18.5.5 or is v18.5.2? V19 EAP can't go from v18.5.2 you have to downgrade to v18.5.1 but v19EAP is supposed to have all the features of v18.5.2 included.

    The above are examples not necessary the correct version or order.

    Ian

    Xeon 1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP

    XG115W - v18.5.2

    If a post solves your question please use the 'Verify Answer' button.

  • Manual download and manual upload of 18.5.2 worked for me to get past 18.0.6.  Thanks for the idea.  Also for others look here for compatibility (use the "upgrade information" button for best info)

    https://docs.sophos.com/releasenotes/index.html?productGroupID=nsg&productID=xg&versionID=18.5 

  • I don't understand either...never in almost 20 years did I have to jump though such hoops do apply a simple firmware upgrade to a UTM appliance. Sure, there were quite a few issues with UTM upgrades in the past few years either, but this was mainly caused by Sophos lack of focus, imo.

    Sophos is really doing everything in its power to steer me off their products for good. I mean, we're talking about firmware release 18.5...XG should be a mature product by now.

    It quite simply is not and this was probably the last straw.