ipv6 prefix delegation over pppoe

Hi,

I'm trying to get ipv6 working.
The dutch provider xs4all gives each end-user a /48 prefix ip addres space.
When I connect to this provider with a Linux box or fritzbox , it seems that I get a /64 prefix delegated for the lan.

However , with UTM , I can't get it working.

I tried with two recent versions of the software appliance

asg-9.109-1.1
asg-9.200-11.1

They're currently running on a esxi5.1 platform.

When using asg-9.109-1.1 , I get sometimes a /48 prefix delegated (visible in the ipv6 menu) but nothing is delegated to the lan interface , even I enter :: in it, or another address in the delegated subnet.

When using asg-9.200-11.1 , i'm getting no delegation at all. 

Of course the automatic renumbering is active in both cases.

In all tests i've taken the time to timeout the previous delegation of the provider.

In all tests i've tested with two different wan setups. With or without VDSL active (just with or without vlan tag).
The behaviour is the same both are working fine with ip4v , and not with ipv6 pd.

I'm able to provide required logging whenever needed.

Kind regards,

Roel
  • With him^ 
    I'm also stuk at the IPv6 (xs4all) thing....

    gr Pascal.


    roel: Weet je nog andere kant-en-klaar pakketten die wel om kunnen gaan met IPv6 van xs4all.
  • Hi Pascal , i've send you a pm in dutch.
  • my ISP also gives out a /48 ipv6 subnet when connected to a Fritzbox over PPPOE, when using the sophos the ipv6 subnet does not "appear" and the interface only gets a link lokal adress.
  • In reply to ben83:

    my ISP also gives out a /48 ipv6 subnet when connected to a Fritzbox over PPPOE, when using the sophos the ipv6 subnet does not "appear" and the interface only gets a link lokal adress.


    Having this same issue,only getting a link local IPv6 address.
    Anyone having any luck ?
  • roku: its currently broken allthough you will get a public ipv6 shown with the latest softpatches.
    Despite only getting a link local shown you have a public ipv6. Enable Masquarading for Ipv6 and visit  http://test-ipv6.com/ to have your public ipv6 shown that the firewall is getting.
  • ben83: Currently running 9.312-8 , found fix 32900 for a similar problem. Still not getting an IPv6 address, even not showing one in the pppoe log. What provider are you using ?
  • roku: local FTTH provider - if you want, i can have a look at your config. PM me incase.
  • ben83: send you an pm.
  • Hi,

    I am also attempting to get this working, when I enable IPV6 I don't get anything showing up in the box.  I can raise tickets through Sophos if necessary since this is a paid unit.

    Thanks.
    Andrew.
  • Hi,

    I have a case open with Sophos now.  However I was wondering if you guys manually set up the IPV6 and eventually saw the delegation in the summary window?  I got the delegation in the summary window only after I ticked the IPV6 default GW on the WAN interface, but I had already manually set up the IPV6 address stuff (the GW config was the last thing I did).  I was just wondering the state of your UTMs with a manually configured IPV6.

    Thanks.
    Andrew.
  • In reply to adhodgson:

    i had a sophos engineer in contact with me with the problem (for my unpaid licence) but kind of stuck right now on that.

    if you have any bug id or ticket # please pm me and i can raise a ticket aswell with our paid work licence.

    adhodgson: my understanding is that the prefix delegation with sophos can only be automatic as you cannot manually enter it anywhere (or?)

    aside from that, when using another ipv6 capable router (with working ipv6 and delegation) in front of the sophos you can use dynamic and have no problem.

    We have a static ipv6 at work now (including a static ipv6 prefix) and i cannot use that prefix. I might raise a ticket for that aswell.
  • Hi,

    Ticket number is 5332491.

    I got it to work by doing the following:

    - Turn on IPV6 in interfaces and routing;
    - Assign the internal interface an IPV6 address from my /64 using a /64 subnet;
    - Create the RA automatic IP assignment using default settings, this also created a DHCPV6 pool as well;
    - Ticked the IPV6 default gateway box in the external interface.

    Once I ticked the default GW on the external interface I could see the delegation on the IPV6 page in interfaces and routing.  I don't know if that was all I needed to do to get it working, or whether the previous steps were also required.  I don't really want to flatten the UTM to try it out since Sophos have remote access to it now.

    Andrew.general IPV5 page in the
  • In reply to adhodgson:


    Once I ticked the default GW on the external interface I could see the delegation on the IPV6 page in interfaces and routing.  I don't know if that was all I needed to do to get it working, or whether the previous steps were also required.  I don't really want to flatten the UTM to try it out since Sophos have remote access to it now.


    are you using IPv6 over PPPoE? sounds odd having to assign a /64 to a network interface to have the IPv6 Tab show any info.

    I ordered a Lancom Router yesterday to serve as a 1st device in front of everything else (including the utm) because Ipv6 just works on those devices and i am tired of having to deal with these problems trying to get it fixed.

    EDIT: To Clarify: In the Lancom Router i can assign parts of the delegated prefix to other Routers/Firewall (such as the Sophos) so i won't be needing PPPoE with the sophos just regular DHCP/DHCPv6 and IA PD to assign a prefix.
  • Hi,

    Ok, here is my experience of getting IPV6 working on the Sophos UTM over PPPOE.  I am with Aaisp in the UK if that helps anyone.

    I am starting from a new configuration on a factory reimaged unit.

    First go through the wizard as normal and set up the PPPOE to your ISP.  Make any changes you want to, then when ready to set up IPV6, do the following:

    On Interfaces and Routing | IPV6, enable IPV6 support on the UTM.  It will show no advertised subnets.

    In Interfaces and Routing | Interfaces, go to your External interface and tick the box to ensure it is the default gateway for IPV6.

    Now go back to Interfaces and Routing | IPV6, and you should see the subnets you have been allocated.

    You now need to assign a static address to the UTM.  I picked the first address in my subnet (a /64), and went to Interfaces and Routing | Interfaces | Internal, and set up the IP address with a /64 subnet.  You will be told if you make a mistake at this point.

    Now go to Interfaces and Routing | IPV6 | Prefix Advertisements and create a new advertisement.  You will be asked for DNS servers, I chose the IPV6 address of the internal interface as my DNS server.  I left all options as default.  This will create a DHCPV6 scope as well but will be hidden.  This means that clients using DHCPV6 will work.

    At this point I rebooted my PC and got IPV6 straight away.  The only issue I found with this was I was being NATted due to the NAT rule which is set up to NAT traffic coming from the internal network and use the WAN address.  This is fine for IPV4 but not IPV6.  I therefore created a network called Internal (IPV4 Network) and assigned the addresses 192.168.0.0/24 to it.  I then amended the NAT rule to use this network and not the default internal network which also included the IPV6 subnet.  At this point HTTP traffic is still coming from the WAN address, but this is due to the web proxy running on the UTM.  If you disable web protection, the system works as advertised.  Also, if you use SSH or other traffic, the correct IP is used.

    I don’t believe IPV6 is broken on the UTM over PPPOE, you just need to configure it as the default gateway.  Furthermore it would be good if the system wouldn’t automatically NAT IPV6 traffic.

    Hope this helps,
    Andrew.
  • In reply to adhodgson:

    adhodgson: sorry not helpful, what you describe is a complete workaround of a not working prefix delegation. When you use Masquarading you can basicly put on whatever prefix you would like.

    this is how it supposed to look: (assigned a /54 from my /48 through my Lancom) - UTM does not do PPPoE for me anymore.