T-Home Entertain / IPTV

Hi,

ich habe heute T-Home Entertain erhalten. Jetzt habe ich ein kleines Problem, das Fernsehen funktioniert soweit, allerdings bleibt der Stream nach ein paar Sekunden hängen. Umschalten auf den nächsten Sender und ich habe wieder ein paar Sekunden. Man könnte das Power Zapping nennen! Wink Die Hotline sagt ist ein unsupportetes Gerät, Auskünfte über Ports können leider nicht weitergegeben werden, nicht für Endkunden bestimmt.

Das Streaming läuft ja über UDP Ports. Hat das jemand am laufen? Ich setze die aktuelle Beta ein mit Kernel Mode pppoe.

Bin über jeden Tipp dankbar und werde mich mal weiter ans Debugging machen...

Danke!

MfG, Mario
  • In reply to Suppentrulli:

    ip-up und ip-down sind doch symlinks? Erstell dir doch einfach jeweils ein separates Script, das unsere plx-scripte startet und danach Deine gewünschten Dinge tut. Auf diese Scripte dann die Symlinks zeigen lassen.
  • In reply to trollvottel:

    Hallo,

    danke für den Tip. Habe ich auch gleich mal ausprobiert, jedoch reichen meine spärlichen Linux-Kenntnisse nicht.

    Ich habe die zwei Shell-Skripte angelegt in denen zuerst das plx aufgerufen wird und dann der igmp-proxy gestartet bzw. gestoppt wird. Auf diese Skripte habe ich die sym.links umgebogen. Berechtigungen habe ich auch entsprechend gesetzt, trotzdem passiert nichts.

    Wie genau müsste der Inhalt meiner Skripte denn aussehen bzw. wie rufe ich das plx und den igmp-proxy-restart auf? Ich fürchte nämlich, dass ich das falsch gemacht habe.
  • In reply to Suppentrulli:

    hi,

    habe auch die 7400 mit vdsl am laufen - in hessen/darmstadt.
    Ich weiss nicht, ob da schon vlan 8 im einsatz ist.

    kann mir jemand einen tip geben, ob die anleitung/konfig von quasar3c279 weiterhin funktioniert? habe soweit alles durchgeführt - scheint aber nicht zu tun... : (
  • In reply to Suppentrulli:

    kann mir evtl. noch jmd. die config erklären, was mit welcher zeile erreicht wird?

    ---
    phyint ppp0 upstream  ratelimit 0  threshold 1
    altnet 217.0.119.193/24
    altnet 193.158.35.0/24
    altnet 239.35.0.0/16
    # IP/Subnet of Media Receiver
    altnet 192.168.2.243/24
    #phyint eth0 downstream  ratelimit 0  threshold 1
    phyint eth0 disabled
    phyint eth2 downstream  ratelimit 0  threshold 1
    phyint eth1 disabled
    phyint lo disabled
    phyint tun0 disabled
    ---
  • In reply to soli:

    Angry wie wäre es mit einem eigenen Thread?

    Zur conf:

    Such mal bei Google nach igmpproxy.conf, da findest du genügend Erklärungen.

    1. Das Upstream-Interface muss dein Internet-Interface sein, bei Astaro ist das ppp0 (wenn du PPPOE nutzt)
    2. Von den IP-Adressen bzw. Netzen die dann angegeben werden, akzeptiert der Proxy Multicasts. Die drei Netze von T-Home müssen angegeben werden sowie die Adresse deines Media-Receivers (den aber bitte mit /32).
    3. Dann kommen die Downstream-Interfaces, für die dein IGMP-Proxy Proxy spielen soll. Wähle NUR das Interface aus, an dem dein Media-Receiver hängt.
    4. Die restlichen Interfaces setzt du auf disabled (mach mal nen ifconfig -a, dann siehst du alle deine Interfaces).

    Noch ein paar Tips:
    - ich würde das 239.35.0.0/16 durch 239.0.0.0/8 ersetzen
    - das musst du dann auch (leider) in der /etc/init.d/igmprtd machen, weil dort die IPTABLES-Einträge gemacht und entfernt werden
  • In reply to Suppentrulli:

    hi,

    danke für die infos, aber irgendwie kriege ich es nicht zum laufen - nach paar sekunden standbild. habe die 7.400 am laufen mit folgender igmp conf:

    ---
    gate:/home/login # vi etc/igmpproxy.conf 
    quickleave


    phyint ppp0 upstream  ratelimit 0  threshold 1
    altnet 217.0.119.193/24
    altnet 193.158.35.0/24
    altnet 239.35.0.0/16


    # IP/Subnet of Media Receiver
    altnet 192.168.3.240/32


    phyint MR-IPTV downstream  ratelimit 0  threshold 1

    phyint eth0 disabled
    phyint eth1 disabled
    phyint lo disabled
    ---

    -den mediareceiver habe ich direkt an ein interface der astaro angeschlossen.

    jemand eine idee, wo mein fehler liegen könnte? gibt es irgendwo eine log möglichkeit?
  • In reply to soli:

    Hi,

    habe gestern den igmproxy mit vdsl in Betrieb genommen. Wichtig ist auf jedenfall, dass man jedes Interface, das in der Astaro mit ifconfig angezeigt wird bei #phyint eth0 downstream  ratelimit 0  threshold 1 disabled auflistet und nur das netzwerk wo der media receiver dran hängt enabled. Ich vermute, dass es bei dir wegen des Interface-Namen nicht funktioniert. phyint MR-IPTV downstream ratelimit 0 threshold 1 dies solltest du in phyint eth2 downstream ratelimit 0 threshold 1 abändern. Logzeilen zum igmpproxy findest du in /var/log/fallback.log

    Meine Konfiguration sieht folgendermassen aus:

    quickleave
    phyint ppp0 upstream  ratelimit 0  threshold 1
    altnet 217.0.119.193/24
    altnet 193.158.35.0/24
    altnet 239.0.0.0/8
    # IP/Subnet of Media Receiver
    altnet 192.168.20.7/24
    #phyint eth0 downstream  ratelimit 0  threshold 1
    phyint eth1 disabled
    phyint eth0 downstream  ratelimit 0  threshold 1
    phyint eth2 disabled
    phyint eth2.7 disabled
    phyint lo disabled
    phyint tun0 disabled
    phyint ipsec0 disabled
  • In reply to andyk007:

    Mach am besten einfach nen ifconfig -a und gib all die dort aufgelisteten Interfaces auch in der conf mit an.
  • In reply to Suppentrulli:

    hallo,

    danke für eure tips.
    scheint nun zu gehen - laut logs war ein fehler in der conf - merkwürdig - habe keinen gesehen.

    noch eine frage:
    wenn ich den receiver über eth0 ueber einen älteren 16 port switch laufen lasse, dann bricht alles zusammen - d.h. ich kann nicht mal mehr meine lan geräte pingen. box aus, kurz warten bis sich alles fängt - und es geht wieder.

    kann es sein, dass ältere switche mit dem multicast nicht umgehen können und alles untergeht?
  • In reply to soli:

    Moin,

    das Problem hatte ich auch, aber auch schon vorher mit dem DDWRT auf meinem Linksys. Problem ist, dass die meisten kleinen(günstigen) Switche kein IGMP-Snooping unterstützen, d.h. der Multicast-Traffic wird an alle Ports weitergeleitet und nicht nur an den, der angefragt hat. Ich hatte noch keine Zeit nach einem Switch zu suchen, der das kann. Ich habe die Box direkt in die DMZ gehängt, durch die Trennung vom LAN sind mir die Probleme erstmal egal. Vielleicht hast du ja auch die Möglichkeit...

    Wie sieht es bei euch eigentlich so mit der Stabilität des IGMP-Proxies aus?

    Gruß, Mario
  • In reply to quasar3c279:

    hallo Mario,

    das mit dem igmp snooping habe ich mir schon gedacht und das war mein erster
    verdacht - das longshine switch ist auch schon sehr alt. ich probiere die tage mal
    andere geräte.

    ich habe die box nun auch an einem seperaten interface, da geht es ohne probleme.
    gestern waren es 2-3h tv stunden ohne ruckler - oder möchstest du auf was 
    bestimmtes hinaus?

    gruss

    ps: auf der cebit hat mir ein techniker bei astaro bestätigt, dass das ding
    von 2 kollegen intern erfolgreich genutzt wird : )
  • In reply to soli:

    hallo soli,

    ich habe manchmal beim umschalten etwas probleme, er braucht dann einen moment bevor er den multicast stream gejoint hat. könnte aber auch daran liegen, dass meine ASG zur Zeit nur 256MB RAM hat, werde die heuet abend mal aufstocken...

    gruß
  • In reply to Suppentrulli:

    hallo mario, suppentrulli,

    habt ihr jetzt irgendwie elegant und automatisiert das nächtlich bzw. das generelle reconnect problem gelöst? habe es heute auch erlebt - ein restart des proxy half.

    info: meine linux konsolen kenntnisse halten sich sehr in grenzen : )
  • In reply to soli:

    also um das reconnect "problem" zu vermeiden habe ich den Zwangsconnect einfach auf eine feste uhrzeit gestellt. 10 Minuten nach dieser Uhrzeit starte ich per crontab den proxy täglich neu. Klar wenn nun natürlich aus irgendwelchen Gründen das DSL auch mal so neustartet muss man den Proxy wiederum manuell neustarten. Finde dies dennoch eine akzeptable Lösung ohne groß die reconnect Konfigurationsscripts abzuändern.

    Viele Grüße
    Andy
  • In reply to andyk007:

    also um das reconnect "problem" zu vermeiden habe ich den Zwangsconnect einfach auf eine feste uhrzeit gestellt. 10 Minuten nach dieser Uhrzeit starte ich per crontab den proxy täglich neu. Klar wenn nun natürlich aus irgendwelchen Gründen das DSL auch mal so neustartet muss man den Proxy wiederum manuell neustarten. Finde dies dennoch eine akzeptable Lösung ohne groß die reconnect Konfigurationsscripts abzuändern.

    Viele Grüße
    Andy


    hi,

    wie genau laesst sich das mit der crontab machen?
    eine detailierte erklärung wäre super : )