Has anyone braved the update to 9.703 yet?

I am trying to find out how you have faired with the new firmware, after the last one bricked one of my firewalls, and I had to go into to work on a Bank Holiday Monday to fix it before the week started! not happy.

so please let me know if you have had any issues, I was holding off on this until I had heard some feedback, but I have not seen any, but then again I have not searched exhaustively across this forum.

  • You don't really need to do an exhaustive search, just a simple 9.703 at the top of the forums will suffice.  I haven't had an issue with it since applying the update.


    and, at the top of the page addressed the only issue anyone really pointed out about it, which has already been fixed.


  • In reply to Amodin:

    Yes, I can see that it seems to be fixed with 9.703-3, but I wanted to find out if anyone had actually taken the plunge and installed it!

    one of the heading actually says "DO NOT INSTALL 9.703", but not which revision, although I do know it is the -2 revision (not the -3)

    I have had a number of issues which the response from Sophos (not their support section but the more senior level teams), leaves a lot to be desire of a professional Security Company.

    1. Red 50 problem that was fixed, then 6 months later (ish) it re-occurred - and they said both times that the issue has been fixed.

    2. release of both the SG and XG firmware which bricks your device - not what I want to hear really.

    3. Sophos released a feature for Central Wireless - which does not work, I am still waiting for the new firmware revision to be released - I believe the firmware update is due out next month.

    4. I have an issue regarding Country Blocking which has taken about a week just to escalate (this second ticket has been open since the start of May), and they are still unable to provide any time frames as to when the problem will be fixed (note that this issue affects both the SG and XG products) - this has been going on since at least end of march that I am aware of.


    I have lost faith in what Sophos says right now.

    apologies rant over

  • In reply to Argo:

    Thanks, the DO NOT INSTALL thread was one I started.  The problem was solved.  I'll go back and mention that in the thread.

    Cheers - Bob

  • In reply to BAlfson:

    I'm actually going to have to remove 9.703-3 I think as I have been seeing issues with not being able to connect to the internet about every two hours since installing this update.  I have to reboot my hardware to get back online. 

    It wasn't apparent at first due to not very much traffic, but since spending some time at home this weekend, it was very apparent to the point of wanting to trash my provider.  Problem is, I don't believe it is them (this time).

    I've had this issue before with UTM and nothing showing up in logs.  I had to redo my UTM to a previous version and wait a firmware update for it to work right again.

  • In reply to Argo:

    Well i have no idea what the legal terms are, but i would like to see a fork of the utm 9

    back to someone like astaro.

    if you had an issue and wrote to the forum and they could relay to it, you had an fix in "no time".


    the way it is for a security product like the utm9 now , is in now way acceptable.



    cheers from germany



  • In reply to Amodin:

    NOTE 01 June 2020: I corrected here to 9.703-3.

    Sorry to hear that, neighbor.  Too bad this is a home UTM instead of a business-use with the ability to open a case with Sophos Support.  Please let us know if the roll back solved the problem.

    Oh, if you haven't already done that, try restoring the backup made just before applying the group of Up2Dates ending in 9.703-3.  Did that work?

    Cheers - Bob

  • In reply to BAlfson:

    The previous one I kept was from 9.702-1 before the Auto Backup of -3.


    I haven't touched it yet, but I wanted to go back to that version.  I basically kept the latest of the past revisions since 9.603-1. 

  • In reply to Amodin:

    Still testing this, but I think this was actually more my ISP than UTM.  The night I was going to reload my UTM, the ISP pushed a firmware update to my modem.  I had also restored from my 9.702-1 backup just before.  I haven't noticed any 'obvious' drops in service yet.  Still testing it out, as I need more time dedicated to being online.  Recent retirement and good weather = honey do lists.  :P

  • In reply to Amodin:

    So, I believe this was the UTM.  I waited a couple of days after the firmware push to my cable modem via ISP.  I was still dropping every couple of hours, like it was doing.  I went ahead and made backups of my UTM configuration, and decided to not use them at all.

    I completely reloaded with a fresh ISO of 9.703-3 and I built my config back from scratch which took a while - I took screenshot snips of my UTM ports, and some setup to build from instead.  I haven't had a problem since.

    My logs were not showing anything related to drops and I could ping the cable modem even when I couldn't get out.  The cable modem was active the entire time, but I could never reach the GUI until the UTM finished doing whatever it was that it was doing.

    This seems to be a problem with UTM every couple of versions for me, without any rhyme or reason, and quite annoying.  This is probably the fourth time I've had to redo my UTM because of this kind of issue with it.

  • In reply to Amodin:

     &  thanks for all the information and very appreciative of the work you have put in, I can only apologise about the vent of frustration earlier.

    But it does seem as though I was right to hold off installing until Sophos actually create an update that doesn't do anything untoward to a working firewall.

    To think that it is a good product, it is just some of the decisions made have really dragged its' name through the gutter.

    here's hoping for the next update ... does anyone have a date on when it might be released?