I can't download Sandboxie

Please tell me how to download Sandoboxie. I've been trying to do so for a few days, Sophos website is the most illogical and complicated one I ever seen. When I try to download it, it makes me to fill a form, I do so, then it says 'We’re sorry. Your request requires further validation before we can proceed, we'll be in touch with you soon'. The robot sent me an email, I didn't get what they want from me. I've been waiting for a few days - nobody contacted me. I went to Sophos site again, logged in, tried to find where the hell can I download Sandboxie...I can't, I give up. Please tell me how.

  • as test
    Just downloaded 5.33.3  64-bit only installer from > https://www.sandboxie.com/DownloadSandboxie
    Yes, I filled out compliance requirements.

    as test
    Just downloaded 5.33.3 combined installer from > https://www.majorgeeks.com/files/details/sandboxie.html

  • In reply to bj m:

    Thank you. But again, it doesn't let me download from the first link. I attach screenshots. Can you please tell me what's wrong? They just sent me an email saying 'thank you for your interest in our products, we currently processing your request, we will contact you soon'. It's been a few days, nobody contacted.

    And about the second link...I don't like downloading anything other than from the official sites, sorry.

  • In reply to Adrew Statham:

    From this distance....?   I'll offer. 

    I've always been able to download Sandboxie.  Just tried, again.  Works for me.  By my experience. I need to Agree to EULA and Submit completed Software Export Compliance form.
    Maybe, try clearing browser cookies n cache.
    Maybe, try another browser.
    Maybe, try switch off browser content blockers ... e.g.,  script block - ad block - tracker block.

    IDK, darn think just always works for me.

    Sorry

  • In reply to bj m:

    I don't have any browser extensions/blockers, I just installed windows a few days ago. But I cleared cache, cookies and everything else, still doesn't work, it keeps saying 'We’re sorry. Your request requires further validation before we can proceed, we'll be in touch with you'. I tried in a different browser - when I press "I agree', the page reloads and it's the same page. I press agree again, and it loads it again. I tried VPN, it says 'access denied'. This is the worse website in the entire internet, I swear. 

  • In reply to Adrew Statham:

    Maybe, try download 5.33.3 combined installer from > https://www.majorgeeks.com/files/details/sandboxie.html ... as test?

    Maybe, post your issue over on Wilders Forums where you'll meet long time Sandboxie users.

    https://www.wilderssecurity.com/threads/sandboxie-acquired-by-invincea.357312/

    Good Luck