[sophos-av] Installation aborted on Ubuntu 19.10

Hello

I tried to install Sophos-AV on Ubuntu 19.10, but without success,i have the following error message


Installation completed.
Installation aborted.
global name 'sys' is not defined"

 when i try install with debug i get the trace below

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "SavForLinux.py", line 27, in main
  File "Controller.py", line 123, in action
  File "Controller.py", line 408, in __install
  File "Controller.py", line 434, in postCleanInstallActions
  File "Controller.py", line 537, in __checkSavd
  File "ActionSupport.py", line 243, in runSavdstatus
  File "savdstatus.py", line 102, in run
  File "savdstatus.py", line 426, in __loadLocalisation
  File "savdstatus.py", line 88, in __saveException
NameError: global name 'sys' is not defined

someone has an idea to solve the problem, in the system requirement the supported distributions is 18.04 LTS but it seem to be a python issue.

thanks

Parents Reply
  • Thanks, DianneY for replay

    i have a business account, with licence for endpoint protection, but there is no version, for Linux workstations, that's why i tried to install sophos-av for my personal use at home, i think i will go back to distro 18.04 because your antivirus has a good reputation in the linux community.

     

     

     

     

     

Children
No Data