This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Install XG Home on XG appliance - How to

Hi All,

I  bought a new XG Appliance to use at home because this box is quite old and cannot perform better than what it is doing at the moment. Next month my ISP will update the speed of the DSL connection, so I need more performance. I bought an XG115 and tried to install XG Home Version on it but it says that an appliance version is detected.

I thought: "I buy an XG appliance and then I can use the home version" but I was wrong. So, no way to use it. I guess the HDD must be changed with another one to get it working.

I was quite sure the XG home was working like astaro with UTM.

Anyone tried this adventure?


This thread was automatically locked due to age.
  • Did You tried to install software version of SFOS?

  • Yes.

    At the installation time, it says "Appliance detected, use the proper ISO".



    Security Architect

    UTM Certified Architect - XG Certified Architect

  • I had a similar problem with the home SG115w, but from what I remember I first installed the hardware version, and then installed the software version. I did not remove the hard drive, I did not open the device at all.

    I installed then SFOS 16.05.3 MR3 and created bootable USB with Rufus 2.9 in DD mode.

  • Hi Luk,

    You can use the same as for CR25iNG in the following link.
    For the XG115 you need to download SW-SFOS_16.05.8_MR-8-305 or V17b2


  • Hi All,

    this is an old thread but during this time I did not have the time to try to install XG on XG115.

    I have tried today to install 17.5 beta2 SW iso and the installation does not go further than this. See the screenshot.

    I did not find any useful thread around the community.

    Please help. I have a new appliance that I want to use at home since my old appliance (where UTM was running is quite old now).



    Security Architect

    UTM Certified Architect - XG Certified Architect

  • Hi All,

    I was able to install XG Home Version on XG 115 device at my home. So the steps I have followed were:

    • Creating a USB drive with Ubuntu latest relese
    • Boot the XG from USB drive
    • "Try the Ubuntu without installing anything"
    • Open the terminal from Ubuntu live and execute: "fdisk -l" XG Appliance does not use partition seems. No partition are availble through fdisk command
    • Creating a fake partition on /dev/sda by using "fdisk /dev/sda", n to create a new partition and follow the command line and press w at the end.
    • poweroff the device
    • unplug the usb drive with ubuntu and then plug the pen drive with XG SW Version
    • Power on the device and boot from usb drive
    • Install the XG version


    In case you need to reuse the XG appliance as appliance, repeat the first 4th steps and remove all the partitions by using fdisk commands.

    Hope these steps will help all.



    Security Architect

    UTM Certified Architect - XG Certified Architect

  • Hi,

    I wanted to give you my feedback, since this workaround did not work for me.

    I followed the steps provided by Luk with a brand new XG115, but with no luck.

    • I confirm that, booting with Ubuntu, /dev/sda has no partitions
    • with Ubuntu I created the partition /dev/sda1 (type 83 Linux, big as the whole disk, 59.6GB)
    • I tried to boot the ISO SW-17.5.1_MR-1-347.iso on the appliance

    But I got the same message "Detected Sophos Physical Device. Please get proper installation source."

    So I think that the fake partition is not enough... I also tried to update the image HW-17.5.1_MR-1-347.iso (worked fine), but the the SW image does not install anyway. Obviously I get the same error if I boot the SW ISO without partition.

    Do you have any ideas? Maybe the partition parameters/type?


    Thank you


  • Hi i tried the same thing with an old SG105W Hardware.

    I had the same problems, this is how i have solved the installation.

    I downloaded a ubuntu server image (ubuntu-18.04.2-live-server-amd64) and burned this to an DVD.
    With an external DVD-ROM i booted ubuntu and did a clean installation of an ubuntu to my Hardware.

    Ubuntu did the job and erased the SSD.

    Next i used the SW-17.5.1_MR-1-347 iso image, burned a DVD and used this to install the XG Home Edition.

    It still Detected Sophos Physical Device, but it installed the SF01V_SO01.

    My Problem is the missing WLAN Card.

    I checked the XG Hardware Image againg an XG SW Image.

    In both images the kernel drivers are present under /lib/modules/kver/kernel/drivers/net/wireless/ath/ath9k*

    But they are not loaded if the SW appliance is installed at the Hardware.

  • Hi Juergen,

    I tried your method (installing Ubuntu and then SW iso) and it worked perfectly, thanks! Yours should be the "definitive" answer.

    Unfortunately I can't help with WLAN card since my appliance is XG115 :(