XG Home V18 freezes after install.

I have a Qotom with a j1900 Celeron, 8GB ram 64GB SSD and 4 Intel NICs.

It has happily been running UTM9 for a while. I tried moving to XG 18 and it freezes after install.
I have tried both SW-18.0.1_MR-1-Build396-396 and SW-18.0.3_MR-3-457
I got the bios set so that it does recognize the drive and I can successfully install with a USB stick. However it does not reboot after pressing y, I must force it off. Then as soon as I connect to the web interface, it freezes.

I can start a continuous ping to, then I connect to the web interface. As soon as I click proceed on the security certificate, I start losing pings.
I go back to the console, and it is not responsive to keyboard input.

I have read all the posts I can find on the subject. The only thing I have not done is start disabling unused hardware in the bios, which I will look into today.
There shouldn’t be any extra hardware though. There is a VGA port, 4 usb, and 4 nics.

Thank you

added tags
[edited by: dlehman at 11:17 AM (GMT -8) on 22 Nov 2020]
  • Can you connect to SSH while using Ping? Thats very odd. Maybe you find the reason there? 


  • I think it could just be a timing thing, something is freezing on startup.
    I was able to ssh in but shortly after it lost ping.
    I didn’t really find anything to disable in the bios but an audio controller.

    I did another test and lost ping without doing anything. From boot roughly a minute before it started responding to pings and another minute and a half it stops responding.

  • Do you have a display to see, if the appliance gets kernel panics or something like that? 


  • Yes I have a display and it doesn't show anything out of the ordinary.  

    It appears to boot normal, I can interact with it for a short time at the console as well, then it just stops responding to any input.  

    I have reverted back to UTM9 for the moment as this is my only firewall / router box.  

    My overall goal was better QoS.  Does XG have better traffic shaping then UTM or was I wasting my time.  

    I will reinstall and try again if there is something different I can try.  


  • If even the keyboard and display does not interact anymore, it seems like the appliance hung and freeze completely for some reason. Could be an issue with the kernel or with the hardware. 

    QoS on XG is much easier to configure, as you can attach it via different approaches. 


  • Yes, I have done a lot of reading of QoS this weekend. I know the UTM QoS is backwards in some respects. However I did have success today and bringing my DSL reports buffer bloat score from an F to an A. This was at the sacrifice of overall top speed.
    I’ll see how this works under real workloads next week.

    The biggest feature I want and have issue with the UTM is knowing who / where is the bandwidth going?
    Clicking on the traffic bar on the dashboard to bring up flow monitor is great, but doesn’t always distinguish between in / out. I have looked to see what appears to be a large amount of traffic coming in for it to say external wan in the details.

    I have played with XG in a VM it looks to have a nice interface, but I’ve not sent any traffic through it to know all the details.

    I assumed wrongly that since these boxes are designed to be firewall appliances and Sophos UTM was working, that it would be compatible with XG.
    My UTM uses under 15% CPU and 20-25% of the RAM. I thought XG would have plenty of resources.

    Thanks for trying today.