This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Android Enterprise; Managed Google Play Apps show as not approved + Policy never applies

Currently deploying Android Enterprise to a single managed Workspace user (shared across 6 devices) in a child OU with third party integration enabled and pretty much everything the initial setup guide requires. (Enabling Admin SDK and Google Play EMM, creating the service account and exporting the token to Sophos)

Note: This is a full control configuration. Device gets setup and enrolls with SMC no problem. After approving a set of Managed Google Play apps I try opening Google Play and navigating to the app in question. App shows as not approved by admin. Trying to perform this via Task Bundle or through remote installation via the Google Play website does not work either. The former task bundle will show as completed and "installed apps" shows as waiting for the devices next sync. Tried manually syncing and decreasing the sync time to 4 hours to no effect.

Trying to get to the install from SMC instead leads to the same prompt. Tried to get around this by opening up the policy to anything in the Play Store and now I receive "This item is not available." Verified that the managed app link takes you to the correct store page and that the app is approved by the google domain administrator account.

I have tried clearing all related Google Play/Services caches--this allows the "view my work apps" tab to show up briefly but if I try and get to the app page again through SMC, it makes that tab dissapear -- not a major issue since I can search the app but still indicative of either a misconfiguration on my part or API not playing well.

Additionally, the device constantly receives a notification to finish signing into it's managed google account -- hitting that, or trying to finish the sign in through system settings, causes a quick redirect to SMC where the device synchronizes and nothing happens.

Lastly, policies applied during enrollment still appear to be setting up. This has been the case for the last couple of hours.

I've been working with support on this issue for the last 3 days and have received no major assistance. The only thing of note would be this detail from a support rep:

"As pe ryour concerns about the app, I have analyzed the logs and found an error. Could you please make sure the device is online, SMC app is running and communicating to Sophos Central :

EST; 2022/12/15 14:50:54; W; Https request failed StatusCode:410 for URL

REST; 2022/12/15 14:50:54; W; Https request failed


The device is clearly able to communicate to Sophos since I can send messages to it and receive confirmation from the Mobile portal. Some assistance with this would be greatly appreciated.

This thread was automatically locked due to age.