Brand New iOS Device - Not Activating with unknown error occurred (6)

I have a brand new iPhone out of the box and update the iOS through iTunes by doing an Restore iPhone to the latest iOS 9.2.1 by downloading the *.ipsw file and doing it the manual way.  I receive the following error message: The iPhone "iPhone" could not be restored. An unknown error occurred (6).  It seems to error out when its trying to verifying iPhone restore with Apple.  I checked the Wireshark, Fiddler, Microsoft Network Monitoring and I couldn't find anything blocking as it seems to connect to gs.apple.com fine

 

I've added the following exception through the web appliance:

iTunes also contacts VeriSign servers during an iPhone restore and activation:

  • evintl-ocsp.verisign.com
  • evsecure-ocsp.verisign.com

 

I activated the brand new iPhone on a standalone Internet connection and it worked fine.  After that I restore the same iPhone to the latest iOS through the network (Sophos Web Appliance) and it worked fine.  Then I tried another iOS Device that isn't out of the box which has probably been updated many times through the Sophos Web Appliance and that worked fine too.  I'm not sure if something is blocking brand new out of the box iPhone