UTM 9.5 Home, Hostname mit DynDNS und SSO über AD

Hallo Leute,

bin relativ neu in der Sophos-Welt und habe seit einer Woche UTM 9.5 auf Hardware als meine private Firewall im Einsatz.

Hab der FW den Namen "ad.domäne.de" gegeben und beim Provider ne Subdomäne mit dem gleichen Namen eingerichtet. Diese dann per DynDNS auf der FW auch eingebunden.

Damit konnte ich dann von aussen per SSL-VPN rein. Klappt also alles nach Plan.

Jetzt wollte ich dazu noch SSO über Active Directory und da fangen meine Probleme an.
Wenn ich meinen AD-Namen beim AD-Joinen eingebe, ist das ja jetzt ein Hostname und wird entsprechend als externe Adresse aufgelöst.

Also kann ich die FW nicht "ad.domäne.de" nennen, da das der Name meiner AD-Domäne ist. Mein DC heisst dementsprechend "server.ad.domäne.de".
Ich kann beim Provider auch keinen DynDNS mit diesem Namen anlegen.

Jetzt habe ich den Hostnamen in "utm.domäne.de" geändert, komme von aussen auch wieder dran, aber das joinen in die Domäne klappt immer noch nicht.

Sollte ich in diesem Fall die Microsoft "Best-Practice" Hinweise fallen lassen und meine AD-Domäne klassisch benennen, wie z.B. "domäne.de"?
Dann könnte ich die Subdomäne "utm.domäne.de" als DynDNS benutzen.

Zusammengefasst würde das heißen:
AD-Domäne:   domäne.de
UTM-Hostname: utm.domäne.de
DynDNS-Host:   utm.domäne.de  -> (ist auch ne Subdomäne beim Provider)

Würde das joinen in die Domäne so funktionieren, oder denke ich hier irgendwo in die ganz falsche Richtung?

Danke für eure Hilfe und noch nen schönen Abend.

  • Anfrageroute im DNS ist aber drin?

  • In reply to ThorstenSult:

    Hi Thorsten,

    danke für den Tipp. Unter Support->Tools->DNS-Lookup wurde der Name meines Servers nicht aufgelöst.
    Darum habe ich unter Definitions&Users->Network-Definitions die Host-Definition geändert und unter DNS-Hostname den Namen eingetragen.
    Dann unter Network Services->DNS->Request Routing eine neue Route definiert mit
       Domain: ad.domain.de
       Target servers: Servername

    Danach funktionierte die Auflösung des Namens von der Firewall aus.

    Allerdings will das joinen immer noch nicht funktionieren........

    ......und jetzt funkts doch !?!?!

    Nach ein paar Minuten und während ich das Post hier schreibe, hab ichs noch mal versucht und es hat BUMMMM gemacht.

    Wow. Danke für den Schubser, Thorsten.

  • In reply to Jürgen Sommer:

    Hallo Jürgen,

    Erstmal herzlich willkommen hier in der Community !

    (Sorry, my German-speaking brain isn't creating thoughts at the moment. Sad)

    Thorsten saw your problem immediately and gave you the solution you needed.  You might also be interested in DNS best practice.

    MfG - Bob (Bitte auf Deutsch weiterhin.)

  • In reply to BAlfson:

    Yeah, thanks for hinting that out. I found that document as i followed Thorstens comment.

    I think it is one of the essential documents to read.