"Activation failed. Undefined error" when trying to activate device

Been unable to activate some iOS devices since around late September to now. Initially the problem appeared when trying to enrol a new iPod, so I went back and checked another device (iPad) which we had enrolled successfully earlier, removed that device from SMC and re-added it and it is hitting the same brick wall of not being able to activate the device in the SMC app. The worst part is, the error message doesn't give you a lot to go on, the text only reads: "Undefined error. Please try again later or contact your administrator". 

I have tried resetting the device and starting from fresh but still running into the same issues. Have tried activating both manually and from clicking on the link on the webpage. 

Both devices are on iOS 11.0.1. We have another iPad (well another 5 iPads) which are identical to the device both in hardware and set up which is having the issue and they seem work fine. 


Any ideas of what to try or what could be causing the error?