version of sophos anti-virus using sav32cli.exe !!

Hello,

I run the command "sav32cli.exe -v" to get the version of Sophos product (Sophos Anti-virus in my case), and I get the following output:

Product version : 1.01.1
Engine version : 3.74.1
Virus data version : 5.68
User interface version : 2.99.009
Platform : Win32/Intel
Released : 24 September 2019
Total viruses (with IDEs) : 41977304

the product version is not 1.01.1, it should be 10.8.2 !! what is wrong here? or what should I do to get the correct version?

thank you and regards,

Jameel

  • Hello Jameel,

    savcli32.exe outputs its own version. While it's no longer available as stand-alone product and uses SAVXP's engine and library it does not depend on SAVXP, technically speaking on SAVXP's version. 10.8.2 is, BTW, an older fixed version.

    Do you want to find out the Sophos Anti-Virus version via command line?

    Christian

  • In reply to QC:

    Hello Christian,

     

    Thank you for the information. And yes this is exactly what I want, I want to get the version of Sophos Anto-Virus via Command Line (cmd or powershell)

    regarding the version 10.8.2, it is planned to have it upgraded to version 10.8.4 soon, but thank you for the hint.

     

     
  • In reply to Jameel Alsarraj:

    Hello Jameel,

    I think SavService.exe's fileversion reflects the product version:
    wmic datafile where name='C:\\Program Files (x86)\\Sophos\\Sophos Anti-Virus\\SavService.exe' get version
    - or -
    powershell.exe -NoProfile -Command (Get-Item 'C:\\Program Files (x86)\\Sophos\\Sophos Anti-Virus\\SavService.exe').Versioninfo.Fileversion

    Christian

  • In reply to QC:

    Hello Christian,

     

    Thanks a lot, these two command worked exactly as I want, have a nice day.