Advisory: Sophos Endpoint - "Your connection isn't private" We're aware of a certificate issue and are actively working to resolve. Please see: KB-000045954 for the latest updates.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Phishing emails not being received by Sophos email

I am trying out the Phis Threat.  I have tried this multipul times, but cannot seem to get it to work.  

To start, I have gone through the entire setup, and I have added the IP's and all of the domains to the whitelist.  The domains are verified.  

I create a campaign, and I have tried sending it to just myself as a test, and to everyone.  The phish threat shows that the email has been sent in the Phish Threat Dashboard and the campaign.  

The email is never received.   I go to my Sophos email security, which is where it should hit first.  There is no record of the email coming in on the logs, and it is not in the quarantine.   I have sent out a test email from the training reminders - automated email setting, and I get that just fine.  When I click on send me a test email from the campaign, it also never arrives.  

In this exmaple, it should be coming from  workplace-wellbeing@hr-benefits.site

I check the mail log for inbound to myself and there is nothing there from the campaign.

Not sure what to do at this point

Any help would be appreciated. 



Added TAGs
[edited by: emmosophos at 7:32 PM (GMT -8) on 16 Feb 2024]