This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Installation of sme64 failed: general error


Can I get an advice what shall I try next on resolving the problem of installation of Endpoint protection on users PC.

The main problem is error:

Last Agent Update - 23 days ago - Update Failed

I had tried reinstalling an Sophos Endpoint protection multiple times but same error occurs at the end of installation  "Failed to install ESH64: general error."

I had checked all log files and searched on google for same problems, there was some suggestions to check some registry values and I did but it didn't help. There was also some suggestions for checking PC's services but same result. 

Sophos UI log - last part

2022-09-27T14:10:42.106Z [ 9200: 1668] I Launching UI in session 1: 5772
2022-09-27T14:10:42.106Z [ 9200: 1668] I Sophos UI Installer completed successfully.
2022-09-27T14:10:42.106Z [ 9200: 1668] I Succeeded: Sophos UI Installer
2022-09-27T14:10:42.107Z [ 9200: 1668] I Action was successful; reboot is not required
2022-09-27T14:10:42.107Z [ 9200: 1668] I End product setup

Only error I had came across is this:

Sophos Endpoint Self Help Install log

setup::MsiInstaller::install: New version: {4EFCDD15-24A2-4D89-84A4-857D1BF68FA8}, version: 3.2.339.0
setup::`anonymous-namespace'::getMsiInformationFromProductCode: ERR: 1612 Failed to open product: {4EFCDD15-24A2-4D89-84A4-857D1BF68FA8}
setup::MsiInstaller::install: Install failed: MsiOpenProductW failed: The installation source for this product is not available. Verify that the source exists and that you can access it.
EshSetup::setResult: installation failed
EshSetup::InstUninstEntry: Installed in: C:\Program Files\Sophos\Endpoint Self Help\
FileOperations::CopyFileForcefully: Copying file 'C:\ProgramData\Sophos\AutoUpdate\Cache\decoded\esh64\Configuration\CustomConfig.json' to 'C:\Program Files\Sophos\Endpoint Self Help\Configuration\CustomConfig.json'
EshSetup::InstallConfig: Successfully copied config file
FileOperations::DeleteDirectoryForcefully: Attempt to delete 'C:\Program Files\Sophos\Endpoint Self Help\Rules'
FileOperations::CopyDirForcefully: Copying dir 'C:\ProgramData\Sophos\AutoUpdate\Cache\decoded\esh64\rules' to 'C:\Program Files\Sophos\Endpoint Self Help\Rules'
EshSetup::InstallRules: Successfully installed rules dir

and in SophosUpdate.log

2022-09-28T07:17:25.968Z [ 4772: 8352] I Successfully established interface IProductSetup2.
2022-09-28T07:17:27.169Z [ 4772: 8352] I Reboot state: 0
2022-09-28T07:17:27.169Z [ 4772: 8352] W Failed to install product 7F682906-6E49-481B-89C5-2DCA36720F4F.
2022-09-28T07:17:27.180Z [ 6076: 4944] E su-setup: exit 1

So please any advice what should I try next is appreciated

This thread was automatically locked due to age.