Improvement request - Still updating a firewall requires so much time

Almost 20 seconds elapsed from the instant when you click apply to the instant you get back to Firewall rule page?

Guys, I hope that you track this as a bug and improve the performance.

Thanks

Parents
  • I know this doesn't add any further to your request but the system load of almost 100 percent per core is unsustainable in a production firewall. I was running system load over 3 on my test firewall in a vm with quad cores. Yes throwing newer, faster hardware will bring it down a little but the system load has increased significantly in v18 compared to v17 and my test lab had only one user mostly playing with the GUI.

    Regards.

  • Hello BillyBob,

    Attached is the load of my test virtual appliance. The load values are not significantly different from the originally used vmware virtual appliance v17.5. Vmware appliance is licensed to 4C6. Appliance runs on ESXi v6.7 U3, Intel (R) Xeon (R) CPU 5120 CPU @ 2.30GHz, RAM 2666GHz, and SAS HDD drive 10k with RAID6.
    However, I have found in the recent past that even with the new installation of ESXi hypervisor v6.7 the hypervisor installer installs very old network card drivers (especially for intel i350), it can be said very "antediluvian" and it is necessary to install the latest drivers using vmware CLI. Throughput is much better after installing current drivers on both network and storage iSCSI layers.

    Maybe this could be the problem with your appliance's poor performance? I don't know what kind of environment you use, I just mention my experience.

    Regards

    alda

  • Plese,

    focus on the topic of the thread.

    If you have poor performance, open another thread. If you have complaint regarding the firewall or any other UI where too much time elapses from the time you click and the time you get back the UI, post here.

    Thanks

    Luk

    Security Architect

    UTM Certified Architect - XG Certified Architect

  • Thanks @alda I was looking at performance on the firewall cli. Didn’t notice my host load. @luk, you are right. I was just trying to correlate slow rule creation to maybe system load. Regards
  • Anyone from Sophos?

    Luk

    Security Architect

    UTM Certified Architect - XG Certified Architect

  •  just rebuilt a 17.5.8 on a J1900 box to compare settings. The box has 1 user, 2 firewall rules and is as slow as a wet week when refrshing the screen of the GUI or any other menu items.

    That reminded me why I built the e3 box to get some realistic screen update times.

    Some redesign of the front end needs to take place to improve the performance otherwise the admin will get very frustrated.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with 2 x APX120 - 20w. 
    If a post solves your question use the 'This helped me' link.
  • Thanks Ian.

    The other day another customer complained about the slowness of the UI. "To create or update a firewall rule requires so much time".....He is still on v17.5.MR8.

    Regards

    Luk

    Security Architect

    UTM Certified Architect - XG Certified Architect

  • Hello All,

    I would expect that some of this is related to the performance of the hardware / VM.

    I have only used Sophos VM's in the training environment. All my customers are using XG Hardware.

    I know that the customers I have with an XG210 and an XG310 are far more responsive in the UI and rule creation than the XG125 that I use in my office.

     

    I also do not have a single customer with anything smaller than an XG125. From back in the Cyberoam days, I installed a single CR15, found it so painfully slow then and lacking the report engine I never ordered another. I have kept this through to today.

    Regards,

    Gavin Daniels. DipIT(Networking)

     

     
Reply
  • Hello All,

    I would expect that some of this is related to the performance of the hardware / VM.

    I have only used Sophos VM's in the training environment. All my customers are using XG Hardware.

    I know that the customers I have with an XG210 and an XG310 are far more responsive in the UI and rule creation than the XG125 that I use in my office.

     

    I also do not have a single customer with anything smaller than an XG125. From back in the Cyberoam days, I installed a single CR15, found it so painfully slow then and lacking the report engine I never ordered another. I have kept this through to today.

    Regards,

    Gavin Daniels. DipIT(Networking)

     

     
Children
No Data