Sophos UTM 9 Anydesk

Hallo zusammen,

ich habe mich heute früh durch diverse Forumbeiträge gelesen, weil ich es nicht hinbekomme Anydesk in unserem Netzwerk freizuschalten.

Sobald ich Anydesk starte, bleibt der Client an dem Punkt stehen, an dem er sich mit dem AnyDesk Netzwerk verbinden will.

Ich habe bereits unter WEB-Protection->Application Control->Application Control Rules eine Regel erstellt, die meinem Testclient die Verbindung zu Anydesk erlaubt und zusätzlich habe ich eine Exception für "^http[s]*:\/\/(.*\.)?anydesk\.com" mit den Skip Checks für Authentication, Caching, SSL Scanning, Certificate trust check, Certificate date Check erstellt.

Trotzdem schlät die Verbindung immer wieder fehl.

In den Logdateien ist klar ersichtlich, dass die Verbindung scheitert, da kein gültiges Zertifikat ermittelt werden kann, aber der Anydesk Client versucht auch immer über IP-Adressen von den jeweiligen Relay Servern zu gehen und nicht über deren DNS Einträgen.

Muss ich jetzt wirklich alle IP-Adressen herausfinden und diese einzelnt freischalten?

Ich habe in einem anderen Beitrag schon eine Liste gefunden, aber ich wüsste nicht wo ich diese importieren kann.

Ich wäre über jegliche Hilfe dankbar!

Liebe Grüße

  • 116.202.225.117 ist die Lösung -> ebenfalls in die Anydesk Web Protection Ausnahme setzen.

    Gruß 

  • Guten Morgen,

    danke für deine schnelle Antwort.

    Meinst du in der Exception List unter Web Protection(->Filtering Options)?

  • Ja genau, einfach eine Webfilter Ausnahme 

    ^https?://([A-Za-z0-9.-]*\.)?anydesk\.com/

    https://116.202.225.117

  • Das hat leider nicht funktioniert. Der Fehler bleibt bestehen

    Ich habe nun allerdings die Relay Server aus einem anderen Forumsbeitrag aufbereitet und importiert, sodass ich nun 387definierte Relay Server habe.
    Damit funktioniert es nun, allerdings bricht bei uns die Verbindung nach genau 5 Minuten immer ab.

    Hattest du schon mal Erfahrungen mit diesem Problem? in den Einstellungen des Clients die Direktverbindung deaktivieren hat nicht funktioniert.

    Trotzdem vielen lieben Dank für die Mühe!

  • Wie schaut denn deine Ausnahme aus? Anydesk kann sich verbinden, sobald man die SSL Ausnahme für die oben genannten URLS setzt. Weil ohne scheitert der initiate Verbindungsaufbau an einem Zertifikatsfehler:

    Auszug Webfilter: 

    url="">https://116.202.225.117/" referer="" error="Failed to verify server certificate" authtime="0" dnstime="1" aptptime="0" cattime="0" avscantime="0" fullreqtime="302748" device="0" auth="6" ua="" country="Germany"

    Dies löst man dann mit der Webfilterausnahme im Bereich -> Webfilter -->Filteroption --> Ausnahmen

  • Ich hab meine Ausnahmen nochmal gelöscht und dein Exceptions hinzugefügt und zusätzlich die beiden Einträge beim Internet-Profil des Rechner hinterlegt als erlaubte Webseiten.

    Hier ein Auszug aus dem LOG:

     url="https://51.91.80.122/" referer="" error="Failed to verify server certificate" authtime="0" dnstime="0" aptptime="0" cattime="0" avscantime="0" fullreqtime="347717" device="0" auth="0" ua="" exceptions="" 

    Der Auszug aus dem LOG ist immer gleich, es wechsel nur die Relay Server.

  • Bei dir ist die Ziel-IP eine andere. Wenn diese fest ist, kannst du diese ja in die Ausnahme setzen.

  • Leider nein, diese wechselt bei jedem Verbindungsaufbau. Ich hab mir jetzt die Liste (Stand vor 3 Monaten) mit den 387 Relay Server genommen und diese importiert. So läuft es erstmal bis anydesk etwas an der Struktur ändert oder neue Relay Server hinzukommen bzw. sich welche ändern.

    Vielen Dank für die Unterstützung :)