This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

a new BUG in V18 GA as well the original server time displayed on reports still broken.

Hi,

there have been a number of discussions about this bug over many releases of XG.

The XG reports do not understand daylight saving. I have started threads on this in the past and is obviously not important to Sophos. Not very professional looking when you can't get your report to generate at the correct time. The following screen shot is taken from the report this supposed to be generated at 1am Melbourne time.

The time the report wa ssent according to the XG.

The report scheduling settings.

The time the report was delivered to me.

Ian



This thread was automatically locked due to age.
Parents
  • Hi folks,

    we are now up to v18 GA and the reporting is still strange.

    I have two daily reports sent to me. V18 has changed the time when one of my reports is generated at 24 hours and the other at 1 hours. The fine tuning has been removed so there is no longer the ability to send a report on the half hour.

    So today I have the following, mind you I am still under daylight savings.

    This is from today's published report.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
  • It seems that devs do not care at all.

    I am struggling with some customers about this. They do not take Sophos seriously on this and on log viewer!

    Luk

    Security Architect

    UTM Certified Architect - XG Certified Architect

  • Hi KingChis,

    the DST is no longer shown in the daily report even though DST is still running in Victoria/Australia.

    I am not running HA.

    I am a home user and therefore do not have access to support.

    In today's example I have two copies of the same web access report from yesterday, I have today's executive report, I have a new copy of yesterday's executive report.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
  • Hi  

    Hmmm....that is going to make troubleshooting this a bit long....

    I would suggest deleting the reports and recreating them to see if that gets rid of any possible duplicated jobs in the timer component.

    Thanks!

    KingChris
    Community Support | Sophos Support

    Sophos Support VideosKnowledge Base  |  @SophosSupport | Sign up for SMS Alerts |
    If a post solves your question use the 'This helped me' link

  • Hi KingChris,

    Devs have access my XG via ZOOM and support tunnels. I was running a ZOOM session with the EAP reporting team yesterday.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
  • Hi  

    As v18 is now GA, all issues go through support.  For the reporting EAP that is a different story.

    Development will not work community issues now that v18 is GA.

    Thanks!

    KingChris
    Community Support | Sophos Support

    Sophos Support VideosKnowledge Base  |  @SophosSupport | Sign up for SMS Alerts |
    If a post solves your question use the 'This helped me' link

  • Hi KingChris,

    The support tunnel option is always there for support to poke around, this has been done before.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
  • Hey Ian,

    Let me follow up with the team regarding this issue.

    Thanks,


    Florentino Sanchez
    Community Manager, Support & Services

    Support Videos | Product Documentation@SophosSupport | Sign up for SMS Alerts
    If a post solves your question, please use the 'Verify Answer' button.
  • Hi Ian,

    I have received 2 reports every time the XG does a change for DST or a firmware update. That should clear out on your next report hopefully. It has for me in the past.

    This is a long standing issue though. NC-29573 and NC-45236 are both part of this issue. I was the one that got both opened. I have been waiting for a fix since V17.0. Hopefully they will fix it soon. I was told V18GA but obviously this didn't happen.

    Mike

  • Hi MichaelB,

    you are confusing two different issues. I understand about extra reports after every software upgrade.

    The DST settings have changed again, now there is no DST addition even though I am still under DST.

    What I am talking about is two or three different reports each day since the upgrade to V18 GA. My XG has been online for just over 3 days after I restarted when re-enabling ATP. Please refer to my earlier post in this thread showing the extra reports delivery. Some are duplicated from the previous day eg two copies of the same report for the same day.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
  • Hi Ian,

    I should have explained more. I know it is a different issue but from your reports, it looks like the same underlying issue with DST. I could be wrong though. Just wanted to share my cases so it could be tracked.

     

    It has been a long time since I went through this with an engineer but if I recall, the OS and system had a different time that the services and processes Sophos uses. I will have to look back at my notes. This caused lots of issues and I had similar report issues as you describe.

     

    One workaround I remember was to change the timezone of the unit, reboot it, change it back, and reboot it again. That fixed it until the next DST change. This won't work with a cluster though.

    Mike

  • Hi MichaelB,

    the DST issue was supposed to be fixed, but hasn't been.

    I have had support look at my XG on this subject in the past and case was created.

    The report now arrive at the same time and according to the date in the reports within minutes of being generated except they are out by an hour and being generated the day before in some cases.

    If need be I can post report dates and associated delivery time/date.

    I originally started this thread in Dec 2017.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
Reply
  • Hi MichaelB,

    the DST issue was supposed to be fixed, but hasn't been.

    I have had support look at my XG on this subject in the past and case was created.

    The report now arrive at the same time and according to the date in the reports within minutes of being generated except they are out by an hour and being generated the day before in some cases.

    If need be I can post report dates and associated delivery time/date.

    I originally started this thread in Dec 2017.

    Ian

     
    V18.0.x - e3-1225v5 6gb ram on 4 port MB with AP55/c - 20w. 
    If a post solves your question use the 'This helped me' link.
Children