Clientless RDP access - websocket error

Recently I connected to Sophos portal and using clientless RDP access to my office computer, I got websocket error in chrome browser.

I tried IE , Edge, opera browser is also same error.

except Firefox 78.0.2, which is all right to use clientless RDP to my office computer. 

As I get through a sophos community, I can't find any solution. 

In chrome, I tried to inspect , it shows following error. (Even I added sophos applicance cert in my remote computer, I still got a same problems)

WebSocket connection to 'wss://x.x.x.x.:xxxx/screenmgr' failed: Error in connection establishment: net::ERR_CERT_AUTHORITY_INVALID

Uncaught TypeError: Cannot read property 'options' of null
at Object.addOption (ui.js?t=1596862095:1079)
at Object.start (ui.js?t=1596862095:90)
at Object.WebUtil.initSettings (webutil.js:155)
at Object.load (ui.js?t=1596862095:45)
at window.onscriptsload (ui.js?t=1596862095:21)
at HTMLScriptElement.loadFunc (util.js?t=1596862095:407)

Please advise any other solution to fix it.

Thanks.

Parents Reply Children
  • Noted. thanks. 

    I checked the log of clientless access log in firewall, it shows following:-

    Aug 13 10:29:25 [4020]: INFO: Client 0: authenticated: user='edtrick'
    Aug 13 10:29:25 [4020]: INFO: Loading bookmark configuration: 'server'
    Aug 13 10:29:26 [4020]: INFO: starting session
    Aug 13 10:29:26 [4020]: INFO: Client 0: start screen requested: server
    Aug 13 10:29:26 [4020]: INFO: Loading bookmark configuration: 'server'
    Aug 13 10:29:26 [4020]: INFO: homedir /tmp/clientless/c962fmkb1bkbt9pg1eddcaeo7/4 setup ok
    Aug 13 10:29:29 [4020]: INFO: Client 0: connector started
    Aug 13 10:29:34 [4020]: INFO: Client 0: disconnected: Broken pipe
    Aug 13 10:30:04 [4020]: INFO: Client 0: connector stopped: 8

    Also for my datacentre firewall XG125, I also tested clientless , also got websocket error. 

    still checking and figure out client side or firewall problems..

     

  • Hi  

    Thanks for sharing this last logs. Is there any coredump on this appliance for core.vncfreerdp ?

    #ls -lah /var/cores

    Regards,

    Vishal Ranpariya
    Technical Account Manager | Sophos Technical Support

    Sophos Support Videos | Knowledge Base  |  @SophosSupport | Sign up for SMS Alerts |
    If a post solves your question use the 'This helped me' link.

  • noted. As I check that no core.vncfreerdp in /var/cores

    In /var/cores , only showing 

    core.avd

    core.awed

    core.ctasd.bin

    core.mailscanner

    core.sandbox_reportd

    core.warren