This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Very slow WLAN using SD-RED20 + wifi module (802.11 AC 2x2 wifi module (for 125w / 135w rev3)


I'm having problem using new RED20 device + WiFi module.

With ethernet speed is just fine, but when connected to wifi connection speed is horrible.

RED's operation mode is Standard/unified.

Tested with various devices. Laptop connects to REDs AP at 300Mbps.

Most of the time Ping is well over 100. At worst over 3000ms.

What could be done to fix this? Firewall we're using is XG 210 running SFOS 17.5.11 MR-11.

Patterns are up to date.


Here's some pics:  


This is the speed with laptop connected to RED's wifi: 


This is the result when connected with ethernet through RED:

This is the Wifi speed when same device connected to APX320 to clarify it's not the client device issue (Not connected to RED):

This thread was automatically locked due to age.
Parents Reply Children
  • Update:

    I disabled RED's wifi module and plugged in APX320 accesspoint. Did everything exactly same way I did with internal wifi.

    Here are the results:

    So there seems to be issue somewhere between RED20 and wifimodule and/or firmware.

  • Which Wireless Mode do you use on XG? 

    Separate Zone or Bridge to LAN? 

    Could you post some Screenshots of your Config? 


    Odd to me, that the APX shows the same results. That would mean, something in the Tunnel is not working properly. Assuming APX works as Separate Zone. If you use Bridge to LAN, does it work? 


  • Corporate network is Bridge to Lan and Guest network is Separate Zone.

    APX320 was working just fine!! There was no probelm at all. The speed was similar to Ethernet and it was as fast as the internet connection allows.

    RED 20 + internal wlan produces about 8/10 (DL/UL) and APX320 close to 90/50.


    And also noticed that is not possible to use 2.4Ghz and 5Ghz at the same time with internal Wifi module. I tried using both for testing purposes. 2,4ghz speed is around 3/5Mbps and 5Ghz speeds are those 8/10Mbps.

    I also had another RED 20 + wifi module going to another customer. Took the wifi module from that and plugged in to this RED unit and the results are the same.



  • Missed this - Sorry. 

    The internal Antenna of RED20 is only Single Radio. Therefore you can only use 5 GHZ or 2,4 GHZ. 


    The poor performance is likely odd to me: Just to be sure, you tested both mode in RED20, separate zone and Bridge to LAN and both results in bad quality? 

    I do not have a Wifi Module at hand to test my RED20. But i am assuming there could be something wrong with the firmware.


    There was a old issue with RED15w and UTM, same results. Maybe there is a regression. Needs to be checked if you can easily reproduce it, it should be easy. 



  • The results are the same at both modes. Tested also with guest network (Separate Zone).

  • Have to say Sophos has just been pure shait (as they say in Trainspotting) when it comes to taking care of this issue!!

    It just could not been any worse.

    Absolutely nothing has been done to this issue. 


    Maybe we just need to start selling other brands to our customers.

  • Hi  

    Please accept our sincerest apologies, I have informed the support team to check and inform you further.


    Community Support Engineer | Sophos Support
    Sophos Support VideosKnowledge Base  |  @SophosSupport | Sign up for SMS Alerts |
    If a post solves your question use the 'This helped me' link

  • Was this issue resolved?  We are experiencing very similar issues with the RED 20s connected to a UTM 9.  What was the resolution on this issue? 

  • It has not been solved yet.

    Sophos thought it's hardware related problem and created RMA. 

    I have not received new device yet.

    I honestly think it will not be solved replacing device. Everything points somehow it's firmware related or just pure compatibility issue between red20 and wifi module.

  • Please can you share the support ticket number for this case.