This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Losing DHCP Gateway

This problem started with 17.5.0 GA.  The firewall is handling DHCP for my lan.  Users have started to lose the default gateway(the Firewall) randomly throughout the day.  I have to either reset the switch or the desktop network adapter in order to regain internet connectivity.  This does NOT happen to all users at the same time.

I updated to XG 115 SFOS 17.5.5 MR5 but the problem still exists.  This actually introduced another problem of not being able to access the gui from Sophos Central, but that's not as pressing.  Any thoughts on this would be appreciated.



This thread was automatically locked due to age.
  • Just upgraded XG230 cluster to SFOS 17.5.5 MR5 last night and this issue started this morning.   Any updates from your side?  Ipconfig /renew or a restart works for us. 

  • You can add me to the list - I thought I was going mad and had configured something incorrectly, good (in a way) to see I'm not alone....

    Tim Grantham

    Enterprise Architect & Business owner

  • I actually do not have the exact same problem, but after restarting a XG all network devices get their DHCP IP addresses but no gateway.

    So it differs a bit, but seems to be quite similar.


    Anyone else?




  • I logged a support request yesterday and got "It looks to be a bug with the latest firmware 17.5.5 MR-5" back via email overnight.  Waiting on support to call me back and will post the outcome here. 

  • In my case, after reboot XG (17.5.5) there is a problem with DHCP, often assigns an IP address but no DNS servers or gateways. The solution is to restart the computer interface, but is this a solution ?? Prior to version 17.5, DHCP worked well. How many more surprises will the Sophos team prepare for us and our clients?


  • Me too.  Seems to happen to some clients more than others.  Has anyone tried going back to 17.5.4?

  • Same issue, some devices loose their gateway and need a refresh DHCP. Devices that leave the network and return mostly.

    The XG external interface also does not update after a link failure which maskes some devices think they have lost their gateway.

    This has been happening on the internal devices since mr-4 was installed.


    V18.0.x - e3-1225v5 6gb ram on 4 port MB with 2 x APX120 - 20w. 
    If a post solves your question use the 'This helped me' link.
  • Me too, After upgraded to latest firmware 17.5.5 MR-5 mostly users are complaining there is no internet and I am only giving the solutions

    1. Plug/unplug Ethernet Cable.

    2. Restart computer.

    3. Disable/Enable Ethernet adapter.

    Kindly suggest the proper solution for this issue or we have to rollback to 17.5.3 MR-3.




  • It seems that once it has the device in the DHCP table, that the gateway and DNS addresses will be issues.

    I have increased the timeout to 30 days, and this seems to have allowed devices that are offline for a couple of days to reconnect fine complete with gateway and DNS information.

    Tim Grantham

    Enterprise Architect & Business owner

  • hi Jan,


    Thanks for your feedback.


    We would need more information and sending you PM