This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Service cannot be updated. It is currently being used in Business Application Rule(s)

Hallo,

wenn I try to edit or change a service in a existing firewall Rule I got the massage "Service cannot be updated. It is currently being used in Business Application Rule(s)"

So everytime I have to remove the service, safe the rule an now I can edit the service. This workaround is very annoying.

My Customers appliances are on Version SFOS 17.0.5 MR-5 and I think the problem exists since version 17.x.x

 

Kind regrets



This thread was automatically locked due to age.
Parents
  •  I tried to edit the rule originally created from the template Email Servers(SMTP) and I have to confirm that it is not really possible add/change/remove ports in a Business Application Rule. As you describe, myloweslife you can add another service/s and then delete the original service/s ( after you replace it with another service/s) but the original service/s can not be edited in any way.

    And I’m also running beta 2.

    Could someone else confirm what Franc found out, resp. that editing this type of firewall rules should not work this way? 

    I think it is clearly a bug.

  • yes its really a bug,i had already tried to create a template from my website securitasepay but it was failed and you can add another services and can remove the original services

Reply Children
  • I also faced the same issue. I to have instructions but I was failed to make changes and it is very inconvenient to have to change one by one. It would be way easier to just edit the port since it is the same for all the rules.