This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How to configure web filter profiles with AD SSO correctly?

Hi @ all,

I'm stuck while configuring the web filter. Hope s/o can  help me. Here's what I did 'til now:

1. created own URL Filtering categories
2. marked them on tab "URL filtering" (block these categories)
3. on webfilter profiles -> Filter action: modified the default content filter block action to block all security issues (e.g. spam..)
4. created additional filter actions: Filter.SocialNetworking; Filter.unwanted; Filter.Webmail
all with the created categories.

5. Filter Assignments -> created the needed assignements for the created filter actions
(Question: If I add a user/group here, this one will bypass the assignment. Right?) 

6. Proxy-Profile -> created WFP.webmail with filter assignment FA.webmail, default content filter block action, standard mode, AD SSO für internal bridged (BrLAN) network.

==Result: Is working

7. created another proxy-profile (2), at position 1

==Result: proxy-profile (2) is working. The first doesn't work anymore.

8. Test: combined the 2 FA to one rule

==Result: only the first in order is used.

Basic configuration was done following THIS Article

(Just edited all AD-Groups from DN to simple Group name)

What I want to archive:
Have several filter profiles assigned to different users/AD Groups, while a user might be in more than one group. With the basic setting in our ASG future configuration can be done by adding users to the appropriate AD-group.

Hope you understand the problem and the goal. Can s/o give me some hints on how to accomplish this?

Thanks in advance!

LoD


This thread was automatically locked due to age.
Parents
  • I would just:
    • rename the 'Default content filter block action' to "IT Prokura filter action"
    • in "IT Prokura filter action', add ^https?://[A-Za-z0-9.-]*facebook\.com and 
      ^https?://[A-Za-z0-9.-]*fbcdn\.net to 'Always allow these URLs/sites'
    • change the "WFP.All" Profile to have 'Ersatzaktion: Default filter action'


    Does it work like you want now?

    Cheers - Bob
     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • Hi Bob and thanks a lot.

    Unfortunately it's not working:
    The "Default Content Filter Block Action" is renamed and now has all unwanted categories (Social networking, webmailer, gmx and more) + the two exceptions mentioned by you.

    The Filter Assignment WFA.All has the "IT Prokura Filter Action" and no users which it applies to.

    The Profile wfp.all has the filter assignment WFA.All + Fallback 'Default Filter Action'

    Although there are no users assigned to WFA.All I can surf facebook but can't reach gmx.de. I expected it to also block facebook, as I'm not one of the 'allowed users/groups' in filter assignments.

    Shouldn't it work like that?

    The webfilter protocol shows:
    statuscode="304" cached="0" profile="REF_HttProWfpall (WFP.All)" filteraction="REF_DefaultHTTPCFFBlockAction (IT Prokura Filter Action)" 


    for gmx but also for facebook.

    Seems there's still someting wrong with my configuration. Hope you'll help me solving this problem.

    Thanks and greetings
    LoD
Reply
  • Hi Bob and thanks a lot.

    Unfortunately it's not working:
    The "Default Content Filter Block Action" is renamed and now has all unwanted categories (Social networking, webmailer, gmx and more) + the two exceptions mentioned by you.

    The Filter Assignment WFA.All has the "IT Prokura Filter Action" and no users which it applies to.

    The Profile wfp.all has the filter assignment WFA.All + Fallback 'Default Filter Action'

    Although there are no users assigned to WFA.All I can surf facebook but can't reach gmx.de. I expected it to also block facebook, as I'm not one of the 'allowed users/groups' in filter assignments.

    Shouldn't it work like that?

    The webfilter protocol shows:
    statuscode="304" cached="0" profile="REF_HttProWfpall (WFP.All)" filteraction="REF_DefaultHTTPCFFBlockAction (IT Prokura Filter Action)" 


    for gmx but also for facebook.

    Seems there's still someting wrong with my configuration. Hope you'll help me solving this problem.

    Thanks and greetings
    LoD
Children
No Data