SG115W internal WiFI Bridge to AP LAN plus external APs, no connection to internal WiFi

We got an SG115W with 3 additional APs.

We planned to use all APs and the internal WiFi for the same SSID, spatially ditributed over the place.

I connected the local Wifi to the WLAN (bridged to AP LAN), created an interface "wlan0" for it and a bridge between ETH0 and WLAN0.

Everything seems fine so far, only that clients are not able to successfully connect to the local Wifi. I received the hint to create a firewall rule internal<->any<->internal (ridiculous, but it worked for a friend with a single SG115W), but nothing changed. Nothing ever connected to the internal WiFi.

I even opened a ticket with Sophos, but the only advice was to disable the bridge between ETH0 and WLAN0. Didn't change anything. Since I could barely understand the guy from india on the phone, I did not try that again.
Someone ever got that working?

Parents
  • Hallo Guys,

    I have this working at many client sites.

    I'm confused about your description of your configuration.  Please post pictures of the Edits of the 'Wireless Network' definition with 'Advanced' open and of the Internal interface definition.

    Cheers - Bob
    PS You can ask that a Support case be escalated.  In Germany, that will probably go to support in UK.

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
Reply
  • Hallo Guys,

    I have this working at many client sites.

    I'm confused about your description of your configuration.  Please post pictures of the Edits of the 'Wireless Network' definition with 'Advanced' open and of the Internal interface definition.

    Cheers - Bob
    PS You can ask that a Support case be escalated.  In Germany, that will probably go to support in UK.

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
Children
  • Hi again,

    I found an instruction and followed it. Can't find it now.

    Wifi config is a such:

    Interface like this:

  • Hallo nochmal Frank, Wink

    When "Bridge to AP LAN" is selected, There's no need to create a bridge.

    In fact, I don't understand how the "Demerius WLAN" NIC used in the bridge could exist.  Normally a virtual wireless NIC is only created when the Wireless Network is defined as "Separate Zone."

    When the original SG 1##w devices came out, there was a problem when choosing "Bridge to AP LAN" with the builtin AP.  I developed the workaround which was to define the Wireless Network as a Separate Zone and then to bridge the resulting wlan# with eth0 for the Internal interface definition.

    By the way, if you're bridging eth0 and eth3, you will need a firewall rule like 'Internal (Network) -> Any -> Internal (Network) : Allow'.

    Cheers - Bob

     
    Sophos UTM Community Moderator
    Sophos Certified Architect - UTM
    Sophos Certified Engineer - XG
    Gold Solution Partner since 2005
    MediaSoft, Inc. USA
  • I guess I found your obsolete instructions and went from there.
    I also already added that ridiculous internal to internal rule.
    Will try to get rid of the Damerius WLAN NIC now.

    Thanks,

    Frank