This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

UTM 9.7 not seeing NICS after BIOS Update.

I have a Fitlet2, with the Intel I211 Ethernet ports. My Sophos UTM has run fine for over 1 year. 

Recently I upgraded the BIOS to ver. 0.46.01.00  After the update, it appears the Sophos UTM 9.7 does not see or load the drivers for the ports as the final screen says I can log in at https://0.0.0.0:4444.

For proof of function, I pulled the Sophos SSD and tried a Windows 10 SSD on the same system, and the Intel I211 Ethernet ports are detected and functioning.  So I have to believe somewhere a Sophos UTM 9.7 configuration file needs to be changed to redetect the Ethernet ports.  

Can anyone help me with suggestions?



This thread was automatically locked due to age.
Parents
  • You could try to restore from a backup and see if the NICs come back, otherwise, a reinstall of UTM would be in order, then restore from a backup.

    UTM - 9.711 | Intel Xeon 4-core v3 1225 3.20Ghz
    16GB Memory | 500GB SATA HDD | GB Ethernet x5

  • A reinstall does not detect the NICS.  So the installation does not proceed with no NICS detected.  This is clearly a Linux issue, and somewhere there is a config file or driver that requires an update.

Reply Children
  • So... I had to look up your device, as I've never heard of those before.  Frankly, I'm surprised you even got UTM to run on that, let alone be efficient.  Looking at the I211 docs, there appears that you have to do a ton of workarounds for thing to work in Linux for the chipset.  Frankly, Sophos isn't at all interested in doing anything with this - just a fact of life with them it seems.

    Personally, the I210/I211 series of NICs have never done anything good for me in UTM and have just dropped my connectivity every other second.  I had to end up getting an Intel 82571 series NIC to work correctly.

    Another option might be to try and load XG to see if it can see the NIC?

    UTM - 9.711 | Intel Xeon 4-core v3 1225 3.20Ghz
    16GB Memory | 500GB SATA HDD | GB Ethernet x5

  • Wow!  surprising information.  Thanks!  I thought that the XG home firewall did not have the same powerful Deep Packet Inspection engine as the UTM with 10s of thousands of patterns?

    Does the XG Firewall have the Country Blocking by region or country with the separate inbound/outbound settings & exceptions?

  • I haven't been involved enough in XG to answer those questions.  I know that there is a lot of opinion about the differences and XG being inferior to some aspects of UTM, but I don't know enough about XG to give an opinion about it.  

    I do know that I'm not a fan of it, mostly because I don't understand it enough to be proficient in setting up rules and such that I have (no migration) and it is enough to make me uninstall it out of frustration.  Others love it.  Might be something to peruse around on the XG forums and see if you can find what answers you are looking for there, as there are also a couple of people there that really know the product.

    UTM - 9.711 | Intel Xeon 4-core v3 1225 3.20Ghz
    16GB Memory | 500GB SATA HDD | GB Ethernet x5