This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Weird UTM freezes randomly approximately once a day ...

I have experienced a strange lockup on my "new" UTM box, but I checked log files and they don't reveal anything, just a bunch of weird characters ...

2023:03:16-01:32:01 escape75 /usr/sbin/cron[25494]: (root) CMD (  nice -n19 /usr/local/bin/gen_inline_reporting_data.plx)
2023:03:16-01:35:01 escape75 /usr/sbin/cron[25649]: (root) CMD (   /usr/local/bin/reporter/
2023:03:16-09:03:10 escape75 syslog-ng[4942]: syslog-ng starting up; version='3.4.7' 2023:03:16-09:03:12 escape75 ddclient[5361]: WARNING: cannot connect to socket: IO::Socket::INET: Bad hostname '' 2023:03:16-09:03:24 escape75 system: System was restarted

So,- I've been running the software version of UTM (9.714) on my old unit (an XG115 r2) for a couple of years without any issues,
and recently I have migrated my saved config over to a new unit (XG115 r3) and a few hours after setting up the new unit (at night)

it froze up, and interfaces were not pingable (LAN) so I powered it down and rebooted. It's working again ...

Just wondering if there's something more I can look at to see what the issue was .. I have a hunch maybe it was DHCP related,
as my devices on the LAN were renewing the IP addresses and they were not in the table on the new unit, but it's a wild guess,
so if this doesn't happen again then maybe it's nothing to worry about.

I don't know if there would be an issue moving the config file (and license) from the old unit, but I wouldn't think so.

The new unit was installed the same way as the old unit, using the ssi-9.714-4.1.iso file and removing the /etc/asg with a software license,
and the old unit hasn't experienced any weird issues in years, and the ethernet ports and devices are setup in an identical way, nothing changed.

Just looking for thoughts and ideas ...

Stats from top:

top - 11:32:20 up 2:31, 1 user, load average: 0.09, 0.29, 0.25
Tasks: 163 total, 1 running, 160 sleeping, 0 stopped, 2 zombie
Cpu(s): 0.6%us, 0.5%sy, 0.0%ni, 98.5%id, 0.1%wa, 0.0%hi, 0.3%si, 0.0%st
Mem: 3898468k total, 3558768k used, 339700k free, 111124k buffers
Swap: 4194300k total, 112k used, 4194188k free, 1352808k cached


root 18256 0.0 0.0 0 0 ? Z 11:30 0:00 [aua.bin] <defunct>
root 18595 0.6 0.0 0 0 ? Z 11:32 0:00 [confd.plx] <defunct>

This thread was automatically locked due to age.
  • I didn't know I could run it without a license ...

  • Well UTM you can just use your existing license file or it comes with a 30-day trial, and XG assigns you one when you download it, and you can see it under Administration > Licensing. 

    OPNSense 64-bit | Intel Xeon 4-core v3 1225 3.20Ghz
    16GB Memory | 500GB SSD HDD | ATT Fiber 1GB
    (Former Sophos UTM Veteran, Former XG Rookie)

  • Define freeze?

    Are you still able to log in locally using the console (serial, vga, etc..)?  If you are able to log in, is there any internet connectivity?

  • Perfect, that's what I'm doing right now, UTM hardware ISO using the 30 day trial, and a basic setup, this will test my XG115 R3.

    I have also re-loaded my XG115 R2 just to see if the other box exhibits the same issues, this should give me some more clues.

  • The unit is completely locked up, I get no response from hitting enter on a USB keyboard, and I cannot ping the LAN bridge interface,
    and the port lights are sporadically blinking in no particular pattern but much slower than what I would normally see when the box is active.

  • I tried serial and it's also not responding, in addition to no pings, and no usb keyboard input.

  • I tried XG115 R2 re-install and use the same config file I've had issues with on my R3, and it's been fine for over 24 hours.

    Then I tried a basic setup with R3, eth1 - WAN, and eth0, eth2, eth3 - LAN (br0) and it went down in about 15 minutes!

    Temperatures seem ok, and memory tested fine, and storage is also OK ... I'm at a loss!

    loginuser@escape75:/home/login > sensors
    Adapter: Virtual device
    temp1: +36.0&***;C (crit = +125.0&***;C)

    Adapter: ISA adapter
    Physical id 0: +36.0&***;C (high = +110.0&***;C, crit = +110.0&***;C)
    Core 0: +35.0&***;C (high = +110.0&***;C, crit = +110.0&***;C)
    Core 1: +35.0&***;C (high = +110.0&***;C, crit = +110.0&***;C)
    Core 2: +35.0&***;C (high = +110.0&***;C, crit = +110.0&***;C)
    Core 3: +35.0&***;C (high = +110.0&***;C, crit = +110.0&***;C)

  • What would be the best way to open a support ticket, is it via:

    I am currently on a 30 day trial of the UTM hardware firmware SG115.

    Thank you!

  • Unless the unit is under warranty, im not sure what kind of support you're expecting.

    Your symptoms sound to me like a hardware issue of some sort; that's why i suggested loading an OS that will allow you to load test and maybe determine what's failing.

  • I am just trying to figure out if there's something obvious or simple I'm missing or doing wrong ...

    For example, the XG115 comes with SFOS by default but I expect I can load UTM as if it was an SG unit.

    It looks like my unit was manufactured in April 2019, I believe it was actually an RMA replacement unit.

    I don't know what my options are at the moment except to return the unit, as it's possibly defective.