Advisory: Sophos Endpoint - "Your connection isn't private." We're aware of a certificate issue and are actively working to resolve it. Please see: KB-000045954 for the latest updates.

[V7.091] Content- and virusfilter show a blank site

Hi,

I'm using V7.091 with WEBFilter. If I want to download a virus-testfile (e.g. eicar.org) or want to visit a ****-page with enabled content-filter Nudity my browsers (IE6, IE7 and Firefox 2.x) get a blank page without any text like in the older versions.
With IE7 I get an error http 403.

Which preferences I have to edit?

Regards
Markus
Parents
  • Hi,

    I'm using V7.091 with WEBFilter. If I want to download a virus-testfile (e.g. eicar.org) or want to visit a ****-page with enabled content-filter Nudity my browsers (IE6, IE7 and Firefox 2.x) get a blank page without any text like in the older versions.
    With IE7 I get an error http 403.

    Which preferences I have to edit?

    Regards
    Markus


    In 7.075 there was an error with customization that caused black content blocked pages. So there are too questions:

    a) Have you changed anything in Management->Customizations?

    b) Any errors in /var/log/http.log when the blank page is delivered to the client?

    Cheers,

    Sven.
  • a) I have cust customized all given texts

    b)
    2007:12:03-12:59:32 (none) httpd[21662]: [warn] mod_fcgid: stderr: Use of uninitialized value in string eq at /PerlApp/wfe/asg/modules/asg_logfiles.pm line 803. 
    2007:12:03-12:59:32 (none) httpd[21662]: [warn] mod_fcgid: stderr: Use of uninitialized value in string eq at /PerlApp/wfe/asg/modules/asg_logfiles.pm line 803. 
    2007:12:03-12:59:32 (none) httpd[21662]: [warn] mod_fcgid: stderr: Use of uninitialized value in string eq at /PerlApp/wfe/asg/modules/asg_logfiles.pm line 803. 
    2007:12:03-12:59:32 (none) httpd: 217.230.66.80 - - [03/Dec/2007:12:59:30 +0100] "POST /index.plx HTTP/1.1" 200 14506 
    2007:12:03-12:59:35 (none) httpd[21408]: [error] [client 217.230.66.80] File does not exist: /var/webadmin/normal, referer: https://frwl-egrh:4444/ 
    2007:12:03-12:59:35 (none) httpd[21408]: [warn] mod_fcgid: stderr: Use of uninitialized value in concatenation (.) or string at (eval 247) line 20. 
    2007:12:03-12:59:35 (none) httpd: 217.230.66.80 - - [03/Dec/2007:12:59:35 +0100] "GET /normal HTTP/1.1" 404 8647 
    2007:12:03-12:59:37 (none) httpd[21662]: [warn] mod_fcgid: stderr: Use of uninitialized value in string eq at /PerlApp/wfe/asg/modules/asg_logfiles.pm line 803. 
    2007:12:03-12:59:37 (none) httpd[21662]: [warn] mod_fcgid: stderr: Use of uninitialized value in string eq at /PerlApp/wfe/asg/modules/asg_logfiles.pm line 803. 
    2007:12:03-12:59:37 (none) httpd[21662]: [warn] mod_fcgid: stderr: Use of uninitialized value in string eq at /PerlApp/wfe/asg/modules/asg_logfiles.pm line 803.

    Good luck
    Markus
  • Hi Markus,

    the logfile you've posted is httpd.log, which contains the log output from webadmin. Please check /var/log/http.log [:)]

    Can you please attach your /var/chroot-http/etc/messages.ini?

    Thanks,

    Sven.
  • Hi Sven,

    I thougth, the logs were the same.

    Here are the log files:
    2007:12:04-20:17:54 (none) httpproxy[4520]: id="0003" severity="info"
    sys="SecureWeb" sub="http" request="(nil)" function="parse_template"
    file="util.c" line="86" message="g_key_file_load_from_file: Key file contains line 'IT Department' which is not a key-value pair, group, or comment "
    2007:12:04-20:17:54 (none) httpproxy[4520]: id="0003" severity="info"
    sys="SecureWeb" sub="http" request="(nil)" function="parse_template"
    file="util.c" line="86" message="g_key_file_load_from_file: Key file contains line 'IT Department' which is not a key-value pair, group, or comment "
    2007:12:04-20:17:54 (none) httpproxy[4520]: id="0003" severity="info"
    sys="SecureWeb" sub="http" request="(nil)" function="parse_template"
    file="util.c" line="86" message="g_key_file_load_from_file: Key file contains line 'IT Department' which is not a key-value pair, group, or comment "
    2007:12:04-20:17:54 (none) httpproxy[4520]: id="0060" severity="info"
    sys="SecureWeb" sub="http" name="web request blocked, forbidden category detected" action="block" method="GET" srcip="aa.bb.cc.dd" user=""
    statuscode="403" cached="0" profile="profile_2"
    filteraction="action_REF_DefaultHTTPCFFAction" size="0" time="0 ms"
    request="0x958fa00" url="www.***.de/" error="" reason="category"
    category="1420" categoryname="Erotic / ***"

    I think, I've found the problem.
    The customiced text has got a 'CR'.
    If I delete the CR, it works. With Version 

    "

    Best regards
    Markus

  • Hi Markus,

    this is what i've expected, as there is a known bug in the customization part. I've fixed this issue yesterday, and it will be released in an up2date.

    Cheers,

    Sven.
Reply Children
No Data