Reflexion will be End-of-life on March 31,2023. See Sophos Reflexion EoL FAQs to learn more.

Bricked APX 320?

Hello,

I recently purchased two pre-owned 320 APX APs for my home.  Both APs boot into solid green, fast flash red, change to solid green, and then flash fast red again.  They never become visible in UTM 9 and appear to be bricked.  I've left them connected for hours, and this cycle never ends.  Resetting has no affect, nor does rebooting during the solid green phase (I didn't boot in flashing red, as supposedly that's a firmware upgrade in progress).

Two questions, if anyone knows:

1) Is this what happens when they're bricked?

2) Where can I download the APX 320 firmware?  I'd like to give the flashing tool a go.


Thanks in advance for anyone's assistance!

Jim

Parents Reply Children
  • Hey, Juergen.

    Here's the follow-up.  The first APX 320 wouldn't reply to the console connection - nothing.  The other one replied, but only spit out gibberish regardless of serial settings.  I started here and tried several different combinations: 

    Speed: 38400, Data bits: 8, Stop bits: 1, Parity: none, Flow control: none - as documented here sophos-operating-instructions-apx-320-530-740-oina.pdf

    I think these devices are done for, one more so than the other.

  • Same thing here. I just picked up an APX 120 "open box" off eBay. Plugged it in, solid red light. Holding the reset button does nothing. No reboot, nothing.

    Odd thing is the Sophos flashing tool does not say it supports the APX 120 in the website's description. If only these devices had a dual BIOS switch inside that could boot with the stock recovery firmware. These access points seem to be built very cheaply but are very expensive especially for home users, with no failsafe incase of a bad firmware flash. Brand new they go for around $300.

    When you can pick up an $80 wireless router, flash it with dd-wrt/OpenWRT and get excellent coverage using it as just an access point.

    My old AP15 is locked at a max 72 Mbps, it's a known issue with the AP access points. I will be seeking more affordable alternatives that can support 802.11ac wireless for a fraction of the cost.

  • I agree.  I really like have an SOHO class UTM firewall for home, as it gives me a lot of flexibility and security, but the used market for APX 320s is a little sketchy.  FWIW, I've bought 4 AP15s and 4 APX 320s over the years, and these two 320s are the only ones that have given me any grief.

  • Hi,

    please set 115200 8N1 , 38400 is not for APX320 and use a good USB/RS232 Adapter.

  • That worked - both devices are now logging to the serial ports and I can read them.  They're stuck in a boot loop due not not findinng a kernel, they boot cycle can't be interrupted by pressing a key, and flashing doesn't work on either device, although the TFTP process does at least start on one device.

    I think it's time to initiate the return.  I provided the seller this link, so I suspect he's satisfied with my diligence.

    Thanks to you and everyone who assisted - it's greatly appreciated!

  • Hi,

    i was able to interrupt the uboot process by changing the autoboot delay to 5s by changing the GD25Q32 content ..
    Just search for bootdelay and change 0 to 5 ... and flash back.

    U-Boot 2012.07 (Dec 05 2017 - 16:05:06)
    
    smem ram ptable found: ver: 1 len: 3
    DRAM:  512 MiB
    machid : 0x8010006
    
    UBI: number of PEBs reserved for bad PEB handling: 40
    UBI: max/mean erase counter: 1/1
    SF: Detected GD25Q32 with page size 4 KiB, total 4 MiB
    Hit any key to stop autoboot:  5
    rnaq-sph1 #