This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Upgrade von SFOS 18.5.4 MR-4-Build418 bricht mit "Upload nicht möglich" immer ab

Hallo allseits,

ich werde seit einiger Zeit bei jedem Login ins Admin-Portal mit der Nachricht begrüßt, ich solle doch endlich mal  auf 19.x upgraden.

Nun wollte ich dem endlich nachgeben und das Upgrade durchziehen, stelle allerdings fest, dass ich es zwar 200x manuell oder automatisch herunterladen kann, aber das Upgrade selbst dann jedes mal abbricht. Beim Auto-Update wird mir nur das Release 19.0.1 MR1-Build365 angeboten, wenn ich übers Sophos-Portal gehe und für meine Seriennummer nachschaue, kann ich 18.5.5, 19.0.1 und 19.5 downloaden.

Aber egal welche ich nehme, sobald ich sie als zweite Firmware hochlade, lädt die Seite einige Zeit und bricht dann mit der Meldung "Neue Firmware konnte nicht hochgeladen werden. Suchen Sie in der Onlinehilfe nach möglichen Ursachen" ab.

Auch ein zwischenzeitlicher Reboot der Appliance sowie die Resync der Subscribtion haben daran nichts geändert.
Ich habe auch die Release-Notes gelesen, allerdings kann ich auch da keine Hürden erkennen. 4GB RAM sind da, das aktuelle Release soll upgradefähig sein und ich habe auch keine BGP-/OSPF-Routings konfiguriert.

Hat irgendjemand eine Idee, woran es scheitert?
Weder die Fehlermeldung noch die Online-Hilfe sind (wie üblich) eine wirkliche Hilfe und natürlich wird über den Abbruch auch nichts im Protokoll geloggt.
Mir gehen so langsam die Ideen aus und ein kompletter Reinstall der Appliance mit der neuen FW wäre aufgrund der Einbausituation wirklich kein Vergnügen...

Danke für hilfreiche Tipps, vielleicht hatte ja hemand schon  das gleich Phänomen...

Viele Grüße

Added TAGs
[edited by: Erick Jan at 1:23 PM (GMT -7) on 9 Jun 2023]
Parents Reply
  • Hallo David,

    nimm doch mal die 18.5.5 und arbeite dich Schritt für Schritt vor. Wenn das geht, dann die 19.0.1 usw.

    Mit freundlichem Gruß, best regards from Germany,

    Philipp Rusch

    New Vision GmbH, Germany
    Sophos Silver-Partner

    If a post solves your question please use the 'Verify Answer' button.

  • For anyone interested in how it all developed:

    Despite all Upgrade-Instructions and FAQs, I did not succeed in migrating from 18.5 to 19.5 directly, neither with different browsers nor by console or ssh. All troubleshooting and log-reading ended without result.

    So here is what I did (and what finally, after investing days trial and error) led to the solution:

    First of all, I made a configuration backup from my running 18.5.4-Config. This was more or less routine, but proved very helpful furtheron.

    Then, after endless tries with the automatic an manual firmware-upgrade to 19.0 or 19.5, which were both of the firmwares, which were proposed to me by the web-interface, I decided to rely on jprusch's hint try the good old step-by-step aproach. So I went to the licensing portal and downloaded 18.5.5, which was the oldest firmware available and higher than my running one.

    After manually downloading 18.5.5, I uploaded it via Web-Interface and to my surprise, this one was accepted. So I rebooted the new version and immediately disabused myself from this misconception, because the firewall hung up in the welcome-screen after upgrade and the web-interface was not reachable. So I read through forums and did some ssh (which luckyly kept working), and so I found out, that tomcat-service was down and not any more restartable.

    At that point I decided to do a rollback to 18.5.4, which was currently loaded as secondary fw, and have my peace without upgrading. Said and done, I rebooted to 18.5.4 by local console and everything worked fine again.

    For whatever reason, I was bothered that much by not having the upgrades, that I tried again two days later.
    And to my surprise, by having the 18.5.5 upgrade in secondary slot, I was now able to upload 19.0.2, which was impossible before. So I uploaded an rebooted 19.0.2 from the running 18.5.4 and was impressed, that this upgrade now ran through without any faults and the firewall successfully rebooted to 19.0.2 with working config.

    So far, so good - but I intended to go for 19.5 from the beginning on, so I decided to wait another day, if everything keeps working and reboots keep effortless, to prove if 19.0.2 was running stable.

    As I was convinced 2 days ahaid, I tried to upload 19.5 now to the secondary slot (formerly 18.5.4), which now succeeded as 19.0.2 before. So i was encouraged to reboot and try the new one, which I did immediately.

    This time, the upgrade and reboot ran through with no problems at first, but I was surprised, that the firewall wasnt reachable even after an our from LAN and all other devices still had no Internet-access.

    So I reconnected local console and made a quick check through the settings menu, and so i figured out, that the upgrade itself was successful, but it came up with factory default settings. That said, I put on the old Lan-config manually an logged in from web-interface again.

    Last but not least, I tried to recover Configuration from 19.0.2, which I backed up before upgrading as every time, but the restore-process told "unable to restore, backup incompatible".
    After screaming in pain, I remembered reading the upgrade instructions weeks ago, which told me, that upgrading from 19.0 to 19.5 will result in config-loss. So I tried one last approach and instead recovered the config-backup from 18.5.4. And believe it or not, this one was working now.

    So, after all, I now do have 19.5.4 running with my old config, as it could have been with one click an 5 minutes, but instead it cost me days of work and many grey hairs...

    I hope, this might help someone else not to search and try for so long!

    Best regards