Sophos XG Firewall - License activation unavailable (error XG-00151). See KB-000043485 for the latest updates.

Benachrichtigungsemails bleiben im Mail-Spool hängen.

Hallo in die Runde, 

ich bin mit meinem Latein am Ende... 

Wir kämpfen seit längerem mit dem Problem, dass die Benachrichtigungen unserer XG210er sporadisch im Spooler hängen bleiben. Wenn man die Mail dann aus dem MailSpool erneut verschickt, kommt diese wie gewünscht an. Komisch ist auch, dass beim eintragen und testen des Mailservers (EXCH2013) die Mail angeblich erfolgreich verschickt wurde, diese aber immer im Spool hängen bleiben. 

Auch Dienst neu starten und Spooler via CLI leeren hat nichts gebracht. Protokoll ist auch nicht aussagekräftig, außer das die Mail abgelehnt wurde. :-/

Aktuellste FW ist installiert, allerdings war das bei den beiden vorherigen Versionen schon das gleiche Spiel. 

Jemand ne Idee?

Parents
  • Hallo,

    solange die Mail im Spooler ist, ist sie ja nicht endgültig abgelehnt.

    Gibt es in der Zeile, wo die "hängende" Mail zu sehen evtl. einen "aktiven bereich", der einem mehr Details verrät, wenn die Maus drüberfährt?

    An wen sollen die Benachrichtigungen gehen ... Intern/extern? Gibt es die Möglichkeit auf dem Mailserver nach der Ursache zu gucken?

    Evtl. passen Zeiten von Graylisting / WiederholungsTimer einfach nicht zusammen.

    Die detaillierteren Logs befinden sich in /log auf der XG  und können dort mit linux-Boardmitteln durchsucht/gelesen werden.

    Siehe

    https://docs.sophos.com/nsg/sophos-firewall/18.5/Help/en-us/webhelp/onlinehelp/AdministratorHelp/Logs/LogFileDetails/index.html#proxy-https-smtps-pop-imap-ftp-waf


    Dirk

    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.

  • Hallo, 

    danke für die Antwort. 

    Leider gibt es zu den Mails keine Details, weshalb diese hängen bleiben. In den Logs habe ich auch nichts erfahren, was ich nicht schon weiß --> Versand Fehlgeschlagen "abgelehnt". Die Mails die hängen bleiben gehen nach intern an Support und Admin. Wenn ich eine Testmail nach extern verschicke, geht diese komischerweise ohne Probleme durch. Also ist es aus meiner Sicht kein Auth-Problem am Exchange. Das irritierende daran ist, dass es beim Wiederholen über den Mail-Spool beim ersten Versuch wieder fehlschlägt und beim 2ten Versuch ansatzlos und ohne Probleme alle Emails aus dem Spool übermittelt werden??? Wenn es mit Graylist oder Repeat was zu tun hätte, dürfte es doch auch bei der Wiederholung nicht funktionieren oder?

    Bei der Prüfung am Exchange finde ich auch nichts hilfreiches in den Logs...

Reply
  • Hallo, 

    danke für die Antwort. 

    Leider gibt es zu den Mails keine Details, weshalb diese hängen bleiben. In den Logs habe ich auch nichts erfahren, was ich nicht schon weiß --> Versand Fehlgeschlagen "abgelehnt". Die Mails die hängen bleiben gehen nach intern an Support und Admin. Wenn ich eine Testmail nach extern verschicke, geht diese komischerweise ohne Probleme durch. Also ist es aus meiner Sicht kein Auth-Problem am Exchange. Das irritierende daran ist, dass es beim Wiederholen über den Mail-Spool beim ersten Versuch wieder fehlschlägt und beim 2ten Versuch ansatzlos und ohne Probleme alle Emails aus dem Spool übermittelt werden??? Wenn es mit Graylist oder Repeat was zu tun hätte, dürfte es doch auch bei der Wiederholung nicht funktionieren oder?

    Bei der Prüfung am Exchange finde ich auch nichts hilfreiches in den Logs...

Children
  • bei mir ist schon einiges Hilfreiches zu abgelehnten mails im smtpd_main.log

    Bei mir wurden die Mails zwar abgelehnt, aber der verbindungsaufbau und der Sendeversuch sind hier auch zu finden...

    35187 T: remote_smtp: for myAddress@gmx.de
    35170   ** myAddress@gmx.de F=<user@mydomain.de> P=<prvs=09293eec1f=user@mydomain.de> R=default_mx_router T=remote_smtp H=mx01.emig.gmx.net [212.227.17.5]:25 I=[192.168.178.222]:43136: SMTP error from remote mail server after initial connection: 554-gmx.net (mxgmx115) Nemesis ESMTP Service not available\n554-No SMTP service\n554-Bad DNS PTR resource record.\n554 For explanation visit www.gmx.net/.../senderguidelines DT=0.372s
    2021-10-22 18:02:26.310 [35170] 2n0m4K-wm3QuA-0I ** myAddress@gmx.de F=<user@mydomain.de> P=<prvs=09293eec1f=user@mydomain.de> R=default_mx_router T=remote_smtp H=mx01.emig.gmx.net [212.227.17.5]:25 I=[192.168.178.222]:43136: SMTP error from remote mail server after initial connection: 554-gmx.net (mxgmx115) Nemesis ESMTP Service not available\n554-No SMTP service\n554-Bad DNS PTR resource record.\n554 For explanation visit www.gmx.net/.../senderguidelines DT=0.372s

    54558 T: remote_smtp: for my.name@somedomain.de
    54542   ** my.name@somedomain.de F=<user@mydomain.de> P=<prvs=09293eec1f=user@mydomain.de> R=default_mx_router T=remote_smtp H=edge01.somedomain.de [111.22.333.73]:25 I=[192.168.178.222]:44272 X=TLS1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=yes DN="/CN=edge01.somedomain.de": SMTP error from remote mail server after RCPT TO:<my.name@somedomain.de>: 550 5.2.1 Mailbox unavailable. Your IP address 88.68.167.39 is blacklisted using BRBL. Details: www.barracudanetworks.com/.../. DT=0.000s
    2021-10-22 18:19:48.378 [54542] 7WtEuf-afdNbj-Lw ** my.name@somedomain.de F=<user@mydomain.de> P=<prvs=09293eec1f=user@mydomain.de> R=default_mx_router T=remote_smtp H=edge01.somedomain.de [111.22.333.73]:25 I=[192.168.178.222]:44272 X=TLS1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=yes DN="/CN=edge01.somedomain.de": SMTP error from remote mail server after RCPT TO:<my.name@somedomain.de>: 550 5.2.1 Mailbox unavailable. Your IP address 88.68.167.39 is blacklisted using BRBL. Details: www.barracudanetworks.com/.../. DT=0.000s


    Dirk

    Sophos Solution Partner since 2003
    If a post solves your question, click the 'Verify Answer' link at this post.