Web Server Protection stopped working

Hello guys!

I have a home server running a few services on port 80 and 2-3 other ports

I also have dyndns (3 hostnames)  and have been using waf to connect to those 3 services without the need to enter a port in the url

(There are also a couple of other services that are accessed by using the port in the url)

Finally, there is also a 4th dyndns hostname that accesses a different machine in port 80

Only the first dyndns (port 80) is really in use, the other three are  mostly for testing.

Yesterday I tried to enter this first one on port 80 and could not connect.

I also tried accessing the 4th which is also using port 80 and could not connect either.

I initially thought that perhaps something happened with my isp (started blocking port 80 or something like that), mainly because another service which is on a different port could be accessed normally using the port in the url

But then I noticed that the other 3 dyndns hostnames were also returning an error when trying to connect (which 2 of them are not using port 80)

So finally realized that "port forwarding" works as it should, however all waf connections do not.

Please keep in mind that I haven't changed anything in the firewall configuration lately.. 

In the afternoon I also reverted to a week old backup, just in case, but I got the same results

 So I can't really understand what has happened.

Do you have any advice regarding where I can check in order to understand what went wrong and waf rules stoppped working?

Thanks!



Edited TAGs to Home/v20
[edited by: Erick Jan at 8:38 AM (GMT -8) on 12 Feb 2024]