Owned SSL Cert not working in captive portal SFOS 19.0.0 GA-Build31

Captive portal in version SFOS 19.0.0 GA-Build31 is not using specified certificate as admin portal.

Captive portal is using SOPHOS cert which is not correct in my setup. See below images.

Have tried fresh re-install, upgrade removing and re-adding the cert an CA detail - not working.



Edited TAGs
[edited by: emmosophos at 10:16 PM (GMT -7) on 19 May 2022]
Parents Reply
  • Hi Vivek

    The certificate is not on the client machine as this is used to ask for authentication on BYOD mobiles which do not have the client cert installed. We are using a LetsEncrypt certificate so that the mobiles are not presented with an invalid certificate. This worked perfectly in 18.5 as the mobiles were presented the captive portal with the LetsEncrypt certificate which they will trust by default.

    The admin page and user page both present the LetsEncrypt cert as expected.

    EDIT: I have reverted back to SFOS 18.5.3 MR-3-Build408 and the expected behaviour has returned (Captive portal is using LetsEncrypt cert as expected).

Children