Sophos UTM: Decommissioning of obsolete URL categorization services CFFS. Click here for important info.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

POPIMAPDEAMON is dead after updating to SFOS 19

Hi, I have the following problem and hope somebody knows this error.

Today I upgrade my Sophos XG Software Appliance from SFOS 18.5.3 MR-3-Build408 to SFOS 19.0.0 GA-Build317. After restart my XG gives me a red status for services with the following massage "POPIMAPDeamon" Dead.

After I got this massage I make a SSH connection to the XG and show wich services are running.

By showing the services I saw that the service "warren" is dead and tried to start it.

Additional Informations:

- I haven´t import or change any certificate settings on the Sophos XG

- This service is used only for backup my Sophos XG via mail

- If I go back to SFOS 18.5.3 MR-3-Build408 the service works probably fine

This thread was automatically locked due to age.
  • Today I found the solution.


    First I was watching the warren.log

    • Make an SSH connection
    • Open the advanced shell
    • cd /log 3. tail -f warren.log

    After that I saw that the problem is with the default certificate of the appliance.

    The solution was to do the following steps.

    1. Chang the CA settings

    • Login to your Sophos XG
    • Go to Certificates
    • Go to Certificate authorities
    • Click on edit by the CA called Default
    • Set here state, company and mail
    • Save

    2. Regenerat the ApplianceCertificate

    • Go to Certificates
    • Click on the gear behind ApplianceCertificate
    • Accept the popup message

    3. Start the warren service

    • Start an SSH connection
    • Open the advanced shell
    • service warren:start -dsnosync

    After that the service is running without any problems.

  • This fixed it for me.  Thank you

Reply Children
No Data