Upgrade to 18.5.1 mr-1 now failsafe mode...

My appliance is intel box 4core 4gb ram 7 nics 128gb ssd

18.0.5 586 works fine i can revert back and all is good.

when i did the firmware upgrade to 18.5.1 mr1 it loads into failsafe mode with the reason "Unable to setup dpdk environment" not sure what that means.

so i pulled the drive and used my identical spare i have for testing and did a fresh install of 18.5.1 same issue...

sometimes it does load into "normal" mode but then when i press "1" for network setup it indefinitely says "please try after some time system initializing" and the network will never load.

for my own sanity i did a fresh install of 18.0.5 586 on this test drive and it boots up no problem super fast

I guess my ask is how to fix... failsafe mode with the reason "Unable to setup dpdk environment"?

This is my first post here so if more info needed let me know.

ps this device i am using is a bit older (core2 quad q9400, ddr2 ram) not sure if that matters but it does work with 18.0.5 no issues



I guess my ask is how to fix... failsafe mode with the reason "Unable to setup dpdk environment"?
[edited by: Jordan Betcher at 2:36 AM (GMT -7) on 5 Nov 2021]
Parents
  • Essentially the dkpk is some sort of integration of the DPI Engine. So likely there is some bad driver or unsupported hardware going on. As you have a odd number of ports, it seems like a custom appliance (other vendor?). 

    Maybe you can try to use V18.5 MR2 (with newer driver) or you could try to go to the BIOS of your appliance and take a look for some vendor specific CPU features. 

    Because failsafe is a state of "i cannot even start the OS". 

    __________________________________________________________________________________________________________________

  • Thanks for the reply...

    Yes this is an old watchgaurd xtm5 with upgraded cpu and ram

    @darktone may have solved my problem (testing now)

    Just weird that the old firmware(s) worked no issues for over a year.

    ill try MR2 as well and update if it works

  • V18.5 MR2 did some upgrades of certain modules in the background. Which could potentially cause a kernel panic for your (not supported hardware). It updated certain crypto modules as well. 

    __________________________________________________________________________________________________________________

  • thanks for your replies! 

    removing the cavium network accelerator card worked in this case and seems to be stable so i am back up and running! 

Reply Children
No Data