This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Nintendo Switch

I was wondering if anyone had any experience in getting a Nintendo Switch to allow online gameplay/eshop etc. when using XG Home Version?  I have been racking my brain for days and cannot seem to get it figured out.  It appears that, in the log viewer almost all packets are being dropped by Rule 0 and I cannot seem to get it working.  It has worked twice for no reason and then stops again.  Any help would be appreciated.

Here is an example of the dropped packet from the log viewer.

messageid="01001" log_type="Firewall" log_component="Invalid Traffic" log_subtype="Denied" status="Deny" con_duration="0" fw_rule_id="N/A" nat_rule_id="0" policy_type="0" user="" user_group="" web_policy_id="0" ips_policy_id="0" appfilter_policy_id="0" app_name="" app_risk="0" app_technology="" app_category="" vlan_id="" ether_type="IPv4 (0x0800)" bridge_name="" bridge_display_name="" in_interface="" in_display_interface="" out_interface="" out_display_interface="" src_mac="" dst_mac="" src_ip="" src_country="R1" dst_ip="" dst_country="USA" protocol="TCP" src_port="54466" dst_port="443" packets_sent="0" packets_received="0" bytes_sent="0" bytes_received="0" src_trans_ip="" src_trans_port="0" dst_trans_ip="" dst_trans_port="0" src_zone_type="" src_zone="" dst_zone_type="" dst_zone="" con_direction="" con_id="" virt_con_id="" hb_status="No Heartbeat" message="Could not associate packet to any connection." appresolvedby="Signature" app_is_cloud="0"
I am also attaching a screenshot of my firewall rule.  Hopefully this helps. 
I have tried disabling web filtering, HTTP/HTTPS scanning, IPS, and Application Control.  Still nothing. 

This thread was automatically locked due to age.
  • Hi,

    first thing to do is remove the linked NAT, you don't need them and they only cause confusion when debugging.

    The rule 0 is hit when a request does not match any firewall rule. Please try again after you have deleted the linked NATs


    XG115W - v19.0.1 mr-1 - Home

    1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP - on holiday.

    If a post solves your question please use the 'Verify Answer' button.

  • I have already tried disabling all of those linked NAT Rules and it still didn't work. 

Reply Children
  • You wed to delete them.

    when you review logviewer please refine the search to the IP address of the switch so you can see what is happening.


    XG115W - v19.0.1 mr-1 - Home

    1225v5 6gb ram, SSID, 4 NICs 20w - v19 EAP - on holiday.

    If a post solves your question please use the 'Verify Answer' button.

  • I deleted the Linked NAT Rule. I already had the log filtered.  Here are a couple of screen shots of the log basic and detailed.  Strange thing was, it worked last night after your last message and then this morning it didn't work.  I didn't change any settings.

  • Create a new rule for the Switch and allow everything to WAN without scanning. Check if this works in the first place. Then try to figure out, which rule is doing something. I assume the "scan http" option is breaking the traffic.


  • LuCar, thanks for your reply.  I have enabled this rule and as of now the traffic is working.  We'll see if it sticks this time. I tried this before, but maybe I made a mistake in my rule.  I will update if it stops working again.  I have included a screen shot of my rule.  No scanning is enabled and logging is on, even though I took the screenshot before clicking the box.

  • Thank you.  This seemed to have fixed the issue.  It has been working fine all day.  My son thanks you too.  Lol.  Must have screwed up my rule the first time I made it.