SATC replacement - Server Endpoint

We had a customer put a case in yesterday about having the Server Endpoint Software configured to replace the failing SATC software. I advised I knew it was in the pipe but hadn't heard it had been released yet, and then he shared these two links:

Set up SATC with Sophos Server Protection

Sophos Firewall: SATC with Server Protection

I worked through it with him, and I'm happy to report it all worked a treat across multiple browsers and clients on his THIN Client. Just thought I'd give anyone a heads up who has been waiting and may have missed the announcement. 



Added TAGs
[edited by: emmosophos at 6:59 PM (GMT -7) on 15 Oct 2021]
  • It is attached to the Server Core Version 2.19.X 

    So if a customer wants to use this, make sure, the Core Agent is updated to a 2.19.X Version. 

    __________________________________________________________________________________________________________________

  • Yeah the customer had to opt in to EAP, the process is in one of the above links.

    ------------------------------------------------

    worlds number one free ICMP monitoring platform: https://pinescore.com

  • found this post by chance.Thanks for posting this

    last week I planned for SATC Client deployment during this week after reading the articles on the Sophos website. Now with EAP enabled and waiting for the Server to receive the 2.19.x beta  I can skip that and only need to create the registry keys on the Terminal Server and add the machine to XG on advanced shell

  • Hello LHerzor,

    unfortunately it's not just about the correct version of the Core agent and EAP participation.The web security in the Core agent have to be disabled. Unfortunately, it is not written anywhere and a colleague solved it with the Sophos GES team for more than two months before the whole solution was fully functional.

    Regards

    alda

  • Hi   ,

    I installed  EAP on a Terminalserver today, set the reg keys, added IP it on the XG, logged on at the TS and could see at least 2 authenticated AD Users with type Thin Client from that IP on the XG Fw.

    Sure, something still needs to be disabled? At least IPS is required to be enabled on the Intercept-X client regarding to the documentation.

  • Hello LHerzog,

    my colleague told me that until web security is disabled in the Core agent on the Terminal Server, the Core agent blocks client access to the Internet. This request was notified from the GES team. Unfortunately, this requirement is not mentioned anywhere.

    I assume he has a statement from the GES team in his email. I could send it to your PM.

    Regards

    Alda

  • thanks for the PN, I have tested WAN website access from that machine:

    as soon as I opened a public website:

    https://www.splunk.com

    here  Splunk as an example, for which I created a firewall rule, I got the denied because of security heartbeat banner on the machine, with the Certificate shown from the Intercept X endpoint

    At the same time, the server lost security heartbeat at the firewall and is now shown as status red there:

    It has not recovered from that state while writing this post.

  • Do you do HTTPS Scanning on the Server? And whats the firewall rule? What are the settings on the firewall Rule? Do you use Kerberos? Because this feature is not kerberos. 

    __________________________________________________________________________________________________________________

  •  yes, I created a FW rule for that server, based on allowed Users and with green source security heartbeat. HTTPS Scan, no decryption.

    The issue is heartbeat on the Intercept-X Client. It cannot get Heartbeat configuration when SATC is set up between Computer and XG Firewall.

    This is the heartbeat log of the client after the reboot I did minutes ago:

    a 2021-11-15T16:05:14.670Z [2040:2080] - ----------------------------------------------------------------------------------------------------
    a 2021-11-15T16:05:14.670Z [2040:2080] - Starting Heartbeat version 1.14.663.0
    a 2021-11-15T16:05:14.670Z [2040:2080] - ----------------------------------------------------------------------------------------------------
    a 2021-11-15T16:05:14.678Z [2040:2188] - No configuration available to establish Heartbeat connection.
    a 2021-11-15T16:20:45.220Z [2040:2188] - The connection configuration has changed. Reloading settings.
    a 2021-11-15T16:20:45.352Z [2040:2188] - Connection succeeded.
    a 2021-11-15T16:20:45.353Z [2040:2188] - Connected to 'xxxxxxx-ede8-xxxxxx-99b1-xxxxxx13f1b' at IP address 52.5.76.173 on port 8347
    a 2021-11-15T16:20:48.349Z [2040:2188] - Sending network status. Active Interfaces:
    MAC: 00:50:56:85:3B:1B - INET: xxx.xxx.xxx.45 - INET6: fe80::xxx:xxx:xxx:7377

    At ~ 16:18 I created a new Central Policy with Web Filtering disabled for that SATC-enabled Server in the Threat Protection Policy

    At ~ 16:20 I clicked on Update on the Client Intercept X.

    At 16:20:45 the heartbeat through the XG firewall was established first time.

    I can now connect to the test website splunk

    Other websites are disallowed as per policy.

    Disabled Webfilter:

    What's the question about Kerberos is about? SATC? Webfilter?

  • I mean, do you use Kerberos (AD SSO) for the zone of the Server on the firewall? Is Kerberos (AD SSO) enabled on your Firewall? 

    Because right now, the heartbeat is not implicate in any way by the HTTPS Scanning of SATC. Because HTTPS Scanning works only for HTTPS (443/80) and the Heartbeat port is another one (8347). 

    Does the firewall use "Match unknown users"? 

    __________________________________________________________________________________________________________________