Error ID: XG-00151 when registering a new XG Home Firewall

I have tried multiple times over the last 3 days to register a new install of XG Firewall Home Edition. Error is:

Error ID: XG-00151

Tracking ID 3495db61-54ff-4c8d-890e-fe9f00e6f9c4

Please help me with registration. Thanks!



Added TAGs
[edited by: emmosophos at 9:36 PM (GMT -7) on 28 Jun 2021]
  • Hello Scott,

    Thank you for contacting the Sophos Community.

    That Tracking ID is used by Customer Care, however, you might get some clues from the licensing.log 

    Make sure there’s no upstream device acting as a Proxy for the Sophos XG

    Regards,


     
    Emmanuel (EmmoSophos)
    Community Support Engineer | Sophos Technical Support
    Sophos Support VideosProduct Documentation  |  @SophosSupport  | Sign up for SMS Alerts
    If a post solves your question use the 'Verify Answer' link.
  • Further to what emmanuel had advised please check the time of your XG.

    Ian

     
    V18.5.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • There are no upstream proxies, just my ISP modem. Time and date are correct. This is the tail of licensing.log while I try to register (removed the serial number and CSR):

    INFO      Jun 28 17:20:45 [4153951680]: --requestType = 2
    INFO      Jun 28 17:20:45 [4153951680]: --lastCheckCode = 00000000-0000-0000-0000-000000000000
    INFO      Jun 28 17:20:45 [4153951680]: --cert = /content/licensing/lic_csr.pem
    INFO      Jun 28 17:20:45 [4153951680]: --token = Token-Id:***masked serial numbder***
    INFO      Jun 28 17:20:45 [4153951680]: --key = /content/licensing/lic_csr.key
    INFO      Jun 28 17:20:45 [4153951680]: URL : eu-prod-utm.soa.sophos.com/.../license
    INFO      Jun 28 17:20:53 [4153951680]: response : {"errorCode":"ITSERVICELAYER_CLIENT_AUTHENTICATION_ERROR","message":"Authentication failed","statusCode":403,"trackingId":"db583091-e427-4b51-b1c9-b0db02255b1f"}
    ERROR     Jun 28 17:20:53 [4153951680]: license_check failed : Authentication failed
    ERROR     Jun 28 17:20:53 [4153951680]: licensing_do_licensecheck() :parsing response failed...
    ####################################################
    generate certificate signing request (CSR)  Mon Jun 28 17:20:54 CDT 2021


    Mon Jun 28 17:20:57 CDT 2021 certificate signing request generated with status :: 0


    ####################################################
    INFO      Jun 28 17:20:57 [4153316800]: --requestType = 4
    INFO      Jun 28 17:20:57 [4153316800]: --serial = ***masked serial number***
    INFO      Jun 28 17:20:57 [4153316800]: --deviceid = ed61df40-c321-480c-878c-ae8bcb1c042f
    INFO      Jun 28 17:20:57 [4153316800]: --cert = /_conf/certificate/licensing/mfgr_vendor_SO.pem
    INFO      Jun 28 17:20:57 [4153316800]: --key = /_conf/certificate/licensing/mfgr_vendor_SO.key
    INFO      Jun 28 17:20:57 [4153316800]: URL : eu-prod-csr.soa.sophos.com/.../signing
    INFO      Jun 28 17:20:57 [4153316800]: certificate_signing_request() : request : {
    "serialNumber":"***masked serial number***",                                       "deviceId":"ed61df40-c321-480c-878c-ae8bcb1c042f",                                              "certificateSigningRequest":"-----BEGIN CERTIFICATE REQUEST-----
    ***masked CSR hash***
    -----END CERTIFICATE REQUEST-----
    "}
    INFO      Jun 28 17:20:58 [4153316800]: certificate_signing_request() : response : {"errorCode":"ITSERVICELAYER_PROVIDER_REQUEST_ERROR","message":"Device must be activated and registered","statusCode":400,"trackingId":"5aefb2e5-ddf6-47bc-8f03-8ace7011a098"}

    ERROR     Jun 28 17:20:58 [4153316800]: Certificate signing Failed : Device must be activated and registered...:(
    ERROR     Jun 28 17:20:58 [4153316800]: certificate signing request() : parsing failed...

  • Hi,

    I would suspect that your licence is not valid, please review your my sophos account and check the licence is correct.

    Ian

     
    V18.5.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • Thank you for the quick replies. I received a serial number from Sophos when I downloaded XG Home, but my Sophos account shows no licenses or serial numbers. I can certainly request another. Is there a way to use a new one without completely reinstalling?

  • You can try using the new serial number because the old one has not been registered, though this would a be guess because I have never tried that approach.

    Ian

     
    V18.5.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • The registration screen does not allow me to change the serial number, so it looks like a reinstall unless anyone has any tricks.

  • I am having the exact same issue on a new install of XG Home. Getting error 151 and can't change the license. Is there a procedure to clear the current and enter a new one? (other than a reinstall..)

  • re-install only after creating a backup.

    Ian

     
    V18.5.x - e3-1225v5 6gb ram with 4 ports - 20w. 
    3 AP55s and 2 APX120s having a holiday until software update is released.
    If a post solves your question use the 'This helped me' link.
  • I'm starting to wonder... I downloaded 18.0 from the Home Firewall page and got a serial number from that. The installation went fine but wouldn't boot afterwards - best I can tell it was due to UEFI (error said there was no bootable disk, I installed Grub from Ubuntu 18, then the error was about a bad UEFI handoff). So then I downloaded 18.5 from the mysophos/account management site. That one installed and booted fine, but I used the original serial number, and now this registration issue. So if there is a difference in the actual binaries between Home and Pro versions, that could be my problem. I'm going to try downgrading the firmware this weekend through the XG web interface to the 18.0 Home version.