Sophos Connect for Mac OS Big Sur

Hi

One of my users has a brand new Mac with Big Sur installed. The Sophos Connect app appears to have installed correctly, but when we click Import Connection, the dialog box to open the config file appears on screen for a split second before disappearing, and the Sophos Connect app freezes.

I presume Big Sur is not supported yet - is there a timeframe for releasing a new version of Sophos Connect that runs on Big Sur?

Many thanks.

  • Hello Stephen,

    I upgraded my Max OSX from Catalina (10.15) to Big Sur (11.0.1) and I am able to import new connections. I also deleted all the connections and then imported them again and I am able to import the connections. Please note in my case it was an upgrade from Catalina to Big Sur.  I uninstalled Sophos Connect and then reinstalled it on  Mac that is running Big Sur and there is no problem with importing new connections.

    Ramesh

  • Hello,

    I have the exact same Problem (new M1 Mac mini). Did you find a solution yet? Uninstalling and reinstalling didn't help either...

    Thanks in advance!

  • Hi Ramesh, thanks for your response. Due to a Covid lockdown here, I haven't actually been able to get back on the Mac yet to have another try with this (it's located off-site).

    This was a brand new Mac which came with Catalina pre-installed, but it prompted the user to upgrade to Big Sur during initial setup, so it looks similar to your upgrade scenario. I will try again and report back when I can.

  • I ran into the exact same issue on an M1 MacBook Air and was able to add the connection using the CLI for Sophos Connect.  See my directions below.

    Copy the scx configuration file to the users desktop

    Open up terminal and run the following commands:
    cd..
    cd..
    cd "library/sophos connect"
    sudo su
    ./sccli add -f /users/userfoldername/desktop/nameofconfig.scx

  • Many thanks, Austin. I've finally managed to get access to the Macbook in question and your directions worked perfectly.

  • I am having the same issue with attempting to import the configuration file and have tried CLI instructions below with no success.

    Anyone else found a work around for this issue?

  • I just checked this again on my M1 MacBook Air and can now import configurations through the GUI instead of CLI.  I'm not sure what changed, but it's working now.  Can you confirm what version of the Sophos Connect client you are using?

  • Thanks for this hint!

    In our environment I had to set up around 20 M1 MacBook Air machines. A small handful of units allowed importing a settings file via GUI, but 90% did not. The import dialog disappears after a fraction of a second. I was unable to find any differences between these machines. Using the Sophos admin tool, I was able to convert our TGB file (which cant be imported using sccli) to the newer SCX file, which in turn could be imported easily. Easily as in Allow-Terminal-full-disk-access-before-the-file can-be-read at least :-)