Sophos UTM: Decommissioning of obsolete URL categorization services CFFS. Click here for important info.

This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Hardware Limitations In Home version

Is it possible to get the hardware limitations removed for the home version?  Or have they been removed in V18?

This thread was automatically locked due to age.
  • C'mon mate, lets imagine that sophos has to pay salaries, developing new solutions, ideas maintain current activities, infrastructure etc etc. We can be glad that sophos is allowing us a home users to using their product just for free with all features. Beside that, for home usage 4 cores and 6 gb is a overkill. With all features on you can gain 1GB/s. look how Fortigate(and other solutions) are expensive, what the are offering etc. With sophos you've got it for free with great community :) appreciate it ^^ and if you wanna use it for commercial just support it - buying it ;)


    HP Small Form Factor:  i5 4Cores, 8Gb of RAM.
    Intel Network Card 5x Eth
    SSD: 256Gb

  • I understand this logic, but there is no reason to limit hardware if it is proven that the UTM is in a home location.  There are tons of other UTM packages out there that don't have hardware limitations.  I don't mind paying the annual license, but to pay the annual license with a hardware restriction is weak.  I guess I'll just stay on PFsense until they finally decide to remove the limitations.  Thanks

  • Look at a Dell OptiPlex 3070 with i3-9100 - that's currently less than £500 with more than enough SSD storage, 8GB RAM.

    Install a PCIe network card, and you'll have the ultimate machine, that's reasonable on power, and also enough throughput.

    Tim Grantham

    Enterprise Architect & Business owner

  • Shame the SFF offering from Dell doesn't have the ability to install a SFF PCI-E NIC.


    The Intel I3-9100T has a lower TDP rating too.  Will look into options further etc.

  • I thought the SFF does - or do you mean the Micro - as I presume the later and yes would be nice if that had a PCI-e slot on it - would be perfect...

    Tim Grantham

    Enterprise Architect & Business owner

  • In that speedtest are you using the IPS and Advanced protection? or just a bare fw rule?


    Because I can max out a 3.6 GHZ processor with 3 cores 6 threads (virtualize) with IPS amd advanced protection at arround 400Mbps upload is much worse.


     Your sophos central account is bussiness or personal? what advanges do you have linking you fw to sophos central?

  • I have IPS and ATP enabled and can get that level of performance, it will depend on your underlaying architecture - the E5-2697v4 CPUs are fairly powerful.


    2x cores of the E5-2697v4 gives the same level of performance as a i5-4400 (Going by CPU benchmark results)

    Tim Grantham

    Enterprise Architect & Business owner

  • BLS said:

    I thought the SFF does - or do you mean the Micro - as I presume the later and yes would be nice if that had a PCI-e slot on it - would be perfect...



    Sorry, yes I was referring to the Micro.


    Currently on a 70/20 Vodafone ADSL connection, just wanting Vodafone to pull their finger out for rolling out Gigafast more.  

  • How many virtual cores are you assigning to Sophos xg?

    Are you using esxi?

    I have a 2400G my single core performance is much better than yours

  • Using ESXi - was 6.5 and now 6.7 - 3 months time will be 7.0 - The VM has been assigned as 1 CPU with 2 core per socket - found the performance better that way.


    So you're on AMD - hmm, I've seen strange things with AMD in the past under virtualisation - where the CPU seems to bog down and not give the full performance when shared between several VMs - so much so that I stick with Intel for any hardware replacement programs, just because I know it will work and work well..

    Tim Grantham

    Enterprise Architect & Business owner

  • Hi,

    it is personal, the history is kept for 7 days.

    I setup the account during beta testing and it is still operational.

    What advantages, for me none really, but I can comment on it in the forums when things are not correct or someone asks for advice.

    CM does offer a couple reports the the native XG does not eg bandwidth usage.


    You do get remote access to your XG without the exposing your external access, not that I need that anymore.


    XG115W - v20 EAP 1 - Home

    If a post solves your question please use the 'Verify Answer' button.

  • This is weird because I don't have any performance issue when I use pfsense or opnsense virtualized

Reply Children
  • But both of those are different architecture - it's a bit like saying GIMP works fast on my machine, but PhotoShop doesn't...


    The other thing to bear in mind is the way that machines handle network configuration - the CPU under certain conditions will take the hit at processing, where on Xeon processors it's more left to the hardware in the Network Card...


    AMD used to be bad for this, and the CPU would load under heavy network traffic.



    I would suspect that the Sophos XG is more at home on Intel platforms than AMD.


    Don't get me wrong, AMD are good, but in the right circumstances - they are great for gaming machines, and general desktop performance.

    Tim Grantham

    Enterprise Architect & Business owner

  • My NIC are Intel i350 and they are passtrough to the VM so there is no emulation. These are enterprise grade nic and the HW offloading is disable you they are doing some work instead the CPU

    What you are mentioning has nothing to do with the CPU but with the network card chipset

    I have had VMs based on FreeBDS, Ubuntu and Centos and have always perform well, so maybe what it is not optimized is Sophos. I am using KVM and as far as I know Sophos is based on Ubuntu/debian

  • I hope you mean that TCP offloading is enabled, otherwise the CPU will be doing a lot of tasks, it will for a lot of tasks that require software inspection such as QoS.

    It potentially is possible that Sophos isn't optimised for AMD hardware, after all given that this is designed to run on their own hardware / Azure which is all intel based (as far as I know / yes there are AMD VMs available in Azure, but you specify them), then why go to the extra effort?

    I'm just going by previous experience, and albeit 3-4 years ago, we noticed that some AMD systems (DL385p G8's) were doing high CPU when transferring SMB traffic, changed to Intel hardware - DL380p Gen8 and it was much faster.

    Tim Grantham

    Enterprise Architect & Business owner

  • BLS said:
    I hope you mean that TCP offloading is enabled, otherwise the CPU will be doing a lot of tasks, it will for a lot of tasks that require software inspection such as QoS.

    By default most of the NIC offload is disabled on XG, I believe It's required for IPS to work in inline mode.


    SFVH_SO01_SFOS 18.0.0 GA-Build379.HF052220.1# ethtool --show-offload Port1
    Features for Port1:
    rx-checksumming: on
    tx-checksumming: off
            tx-checksum-ipv4: off
            tx-checksum-ip-generic: off [fixed]
            tx-checksum-ipv6: off
            tx-checksum-fcoe-crc: off [fixed]
            tx-checksum-sctp: off [fixed]
    scatter-gather: off
            tx-scatter-gather: off
            tx-scatter-gather-fraglist: off [fixed]
    tcp-segmentation-offload: off
            tx-tcp-segmentation: off
            tx-tcp-ecn-segmentation: off [fixed]
            tx-tcp-mangleid-segmentation: off
            tx-tcp6-segmentation: off
    udp-fragmentation-offload: off
    generic-segmentation-offload: off
    generic-receive-offload: off
    large-receive-offload: off
    rx-vlan-offload: off
    tx-vlan-offload: off

    If a post solves your question use the 'Verify Answer' button.

    Ryzen 5600U + I226-V (KVM) v20 EAP1 @ Home

    XG 115w Rev.3 8GB RAM v19.5 MR3 @ Travel Firewall

  • Hi,


    Can you change your search method from ac-bfna to hyperscan and do the same test again?

    Here's the difference by the default IPS options in XG to changing it to hyperscan, you can use "set ips search-method hyperscan" to change it.



    Default (ac-bfna):

    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-10.00  sec   989 MBytes   830 Mbits/sec                  receiver



    [ ID] Interval           Transfer     Bitrate
    [  5]   0.00-10.00  sec  2.71 GBytes  2.33 Gbits/sec                  receiver


    Both of them where using only a single core from my XG.

    Also there's lot's of issues using XG with AMD hardware on KVM, primarily with SSL/TLS Decryption throughput.


    Using SSL/TLS Inspection:

    Saving to: ‘iso’

    iso                  11%[>                ] 207.05M  34.2MB/s


    Using Web Proxy:

    Saving to: ‘iso’

    iso                  14%[=>               ] 260.74M   217MB/s


    The CPU has a AMD Ryzen R7 1700.



    Edit: The results on ESXi is much better than KVM.

    Using the SSL/TLS Inspection with Decryption + IPS; I can get 70MB/s over a single core, which is the expected throughput for the CPU without using AES-NI. Also the same throughput I've got over a single core on a AMD Ryzen 3 2200G.

    So the issue is pretty much only on KVM.



    If a post solves your question use the 'Verify Answer' button.

    Ryzen 5600U + I226-V (KVM) v20 EAP1 @ Home

    XG 115w Rev.3 8GB RAM v19.5 MR3 @ Travel Firewall

  • The VM has assinged 3 cores with its 6 threads, the topology is correctly defined in KVM

    Without IPS, with Advanced Protection and Web filtering without breaking SSL.

    2 threads at 80%

    Same as before but with IPS and 3437 selected

    I get this with 5 threads 95% average on download, upload is 55% average for 5 threads

    Same as before but with Hyperscan,

    5 threads at 60%


    The IPS is a LAN WAN generic profile basically


    So hyperscan somehow worked but still upload speed are bad (maybe becasue the IPS rules are LAN-WAN)

    Is there any other way to improve the performance? maybe adding another snort instance? how is the command exactly? "ips-instance"

  • Yes mine is OFF as well I though it was enable since it is in pfsense/opnsense


    SFVH_KV01_SFOS 18.0.0 GA-Build354.HF052220.1# ethtool --show-offload PortA      
    Features for PortA:                                                             
    rx-checksumming: on                                                             
    tx-checksumming: off                                                            
            tx-checksum-ipv4: off                                                   
            tx-checksum-ip-generic: off [fixed]                                     
            tx-checksum-ipv6: off                                                   
            tx-checksum-fcoe-crc: off [fixed]                                       
            tx-checksum-sctp: off [fixed]                                           
    scatter-gather: off                                                             
            tx-scatter-gather: off                                                  
            tx-scatter-gather-fraglist: off [fixed]                                 
    tcp-segmentation-offload: off                                                   
            tx-tcp-segmentation: off                                                
            tx-tcp-ecn-segmentation: off [fixed]                                    
            tx-tcp-mangleid-segmentation: off                                       
            tx-tcp6-segmentation: off                                               
    udp-fragmentation-offload: off                                                  
    generic-segmentation-offload: off                                               
    generic-receive-offload: off                                                    
    large-receive-offload: off                                                      
    rx-vlan-offload: off                                                            
    tx-vlan-offload: off                                                            
    ntuple-filters: off [fixed]                                                     
    receive-hashing: on                                                             
    highdma: on [fixed]                                                             
    rx-vlan-filter: on [fixed]                                                      
    vlan-challenged: off [fixed]                                                    
    tx-lockless: off [fixed]                                                        
    netns-local: off [fixed]                                                        
    tx-gso-robust: off [fixed]                                                      
    tx-fcoe-segmentation: off [fixed]                                               
    tx-gre-segmentation: off [fixed]                                                
    tx-gre-csum-segmentation: off [fixed]                                           
    tx-ipxip4-segmentation: off [fixed]                                             
    tx-ipxip6-segmentation: off [fixed]                                             
    tx-udp_tnl-segmentation: off [fixed]                                            
    tx-udp_tnl-csum-segmentation: off [fixed]                                       
    tx-gso-partial: off [fixed]                                                     
    tx-sctp-segmentation: off [fixed]                                               
    tx-esp-segmentation: off [fixed]                                                
    fcoe-mtu: off [fixed]                                                           
    tx-nocache-copy: off                                                            
    loopback: off [fixed]                                                           
    rx-fcs: off [fixed]                                                             
    rx-all: off [fixed]                                                             
    tx-vlan-stag-hw-insert: off [fixed]                                             
    rx-vlan-stag-hw-parse: off [fixed]                                              
    rx-vlan-stag-filter: off [fixed]                                                
    l2-fwd-offload: off [fixed]                                                     
    hw-tc-offload: off [fixed]                                                      
    esp-hw-offload: off [fixed]                                                     
    esp-tx-csum-hw-offload: off [fixed]                                             
    rx-udp_tunnel-port-offload: off [fixed]            
  • That upload limit while using IPS is very strange.

    Nice to see there has a noticeable change from ac-bfna to hyperscan on your setup.


    The command to add more Snort instances is "set ips ips-instance  add IPS cpu <core>"


    Another thing,what AMD CPU are you using right now with KVM? For better performance (if you are using proxmox or straight kvm with qemu) leave as 6 sockets instead of 3 cores and 6 threads.


    Also, can you do the same speed test but with "generalpolicy" as the IPS Rule?



    If a post solves your question use the 'Verify Answer' button.

    Ryzen 5600U + I226-V (KVM) v20 EAP1 @ Home

    XG 115w Rev.3 8GB RAM v19.5 MR3 @ Travel Firewall

  • I don't have "generalpolicy" maybe I have deleted it but I have tried with "LAN to WAN" (one of the defaults policies) and the result is the same.

    I use KVM QEMU 4.2 with Unraid, this section of the config file reflects my CPU configuration

     <?xml version='1.0' encoding='UTF-8'?>
    <domain type='kvm' id='1'>
        <vmtemplate xmlns="unraid" name="Linux" icon="linux.png" os="linux"/>
      <memory unit='KiB'>6291456</memory>
      <currentMemory unit='KiB'>6291456</currentMemory>
      <vcpu placement='static'>6</vcpu>
        <vcpupin vcpu='0' cpuset='0'/>
        <vcpupin vcpu='1' cpuset='4'/>
        <vcpupin vcpu='2' cpuset='1'/>
        <vcpupin vcpu='3' cpuset='5'/>
        <vcpupin vcpu='4' cpuset='2'/>
        <vcpupin vcpu='5' cpuset='6'/>
        <type arch='x86_64' machine='pc-q35-4.2'>hvm</type>
      <cpu mode='host-passthrough' check='none'>
        <topology sockets='1' cores='3' threads='2'/>
        <cache mode='passthrough'/>
        <feature policy='require' name='topoext'/>
      <clock offset='utc'>
        <timer name='rtc' tickpolicy='catchup'/>
        <timer name='pit' tickpolicy='delay'/>
        <timer name='hpet' present='no'/>



    The settings that are changed via console are maintained in a backup?

  • l0rdraiden said:
    <topology sockets='1' cores='3' threads='2'/>


    <cpu mode="host-passthrough">
        <topology sockets="8" cores="1" threads="1"/>

    That's my current settings for CPU on one of my XG VM's.



    If a post solves your question use the 'Verify Answer' button.

    Ryzen 5600U + I226-V (KVM) v20 EAP1 @ Home

    XG 115w Rev.3 8GB RAM v19.5 MR3 @ Travel Firewall